harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <g...@pobox.com>
Subject Re: [drlvm] Need help debugging
Date Sat, 09 Sep 2006 13:30:49 GMT
There is this in the tracestream :

exit method java/lang/VMStart initialize ()V
ExceptionOccurred called
Exception occured, no exception
??????????F
ExceptionDescribe called
DestroyVM  called
ExceptionOccurred called
Exception occured, no exception
FindClass called, name = java/lang/VMStart
FindClass called, name = java/lang/VMStart
si_goto_previous from ip = (nil) (M2N)
si_unwind_from_m2n, ip = (nil)
si_goto_previous to ip = (nil) (M2N)
0x8521890 0x8085540 I java/lang/VMStart
Loader U (0x8521890) loading class: java/lang/VMStart...
enter method java/lang/ClassLoader loadClass 
(Ljava/lang/String;)Ljava/lang/Class;
GetStringUTFLength called
GetStringLength called
GetStringUTFRegion called
ExceptionOccurred called
Exception occured, no exception
GetStringUTFLength called
GetStringLength called
GetStringUTFRegion called
ExceptionOccurred called
Exception occured, no exception
exit method java/lang/ClassLoader loadClass 
(Ljava/lang/String;)Ljava/lang/Class;
0x8521890 0x8085540 R java/lang/VMStart
ExceptionOccurred called
Exception occured, no exception
GetStaticMethodID called
GetStaticMethodID java/lang/VMStart.shutdown ()V = 0x830d4cc

I wonder what the "?????????F" is

geir

Geir Magnusson Jr. wrote:
> There is an InternalError thrown (see the tracestream), but I haven't 
> found  way to figure out what that is yet...
> 
> geir
> 
> Geir Magnusson Jr. wrote:
>> I was testing the DRLVM-in-Launcher setup and something is seriously 
>> broken.
>>
>> On Ubuntu, both debug and release builds, it will run Tomcat ok, but 
>> when I try something like Eclipse 3.2 or ActiveMQ 4.0.2 the program 
>> runs and silently exits.  No log output, no console output.
>>
>> I've been trying to find a hint of what is making it unhappy, but so 
>> far, no luck.
>>
>> I've been staring at the output with -Xlog and -Xtrace, and there 
>> doesn't seem to be any errors, but I don't know what to look for.  (
>>
>> I've captured the stream and placed it here :
>>
>>   http://people.apache.org/~geirm/activemq-logstream-20060909.txt
>>   http://people.apache.org/~geirm/activemq-tracestream-20060909.txt
>>
>> If anyone has any hints, I'd be mighty obliged...
>>
>> geir
>>
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>>
> 
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
> 

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message