harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Zhang" <zhanghuang...@gmail.com>
Subject Re: [app-bug] NIO problems when running Apache MINA examples
Date Thu, 24 Aug 2006 04:45:08 GMT
Hi Sian,

Thanks for reporting the error. But it works well on my machine when running
org.apache.mina.examples.echoserver.Main. The error can not be reproduced in
my machine with latest code.

After looking the error statck trace, I noticed the bug is mostly possible
the same as Harmony-1186 (http://issues.apache.org/jira/browse/HARMONY-1186).

If I restore harmony code with early revision (before Harmony-1186,
revision 431877), the error can be reproduced exactly the same as you
reported. Harmony-1186 was fixed on Aug.16, but you built the snapshot on
Aug.21...(So I'm not sure whether they are the same bug). So could you
please check whether your source code is updated with latest revision, if
you built the snapshot by yourself? Othewise, it may work if you download
the snapshot from harmony website (I checked the snapshot was made on Aug.17).
Or would anyone update the snapshot on the website?

I hope it works. If you still fail to run mina examples, please let us know.
Any information are highly appreciated!  Thank you!

Best regards,
Andrew

On 8/23/06, Sian January <sianjanuary@googlemail.com> wrote:
>
> Hello,
>
> I have recently downloaded Apache MINA, which is a framework for writing
> network applications, and tried to run some of the examples with Harmony.
> There were some problems getting the examples to run and if anyone is
> interested in taking a look I think I have found an NIO bug -
> http://issues.apache.org/jira/browse/HARMONY-1270.
>
> Regards,
>
> Sian January
>
> IBM Java Technology Centre, UK
>
>


-- 
Andrew Zhang
China Software Development Lab, IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message