harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jimmy, Jing Lv" <firep...@gmail.com>
Subject [ClassLib][Instrument]Put tests to Harmony (and Support_Exec)
Date Thu, 24 Aug 2006 08:16:12 GMT
Hi,
     The development on instrument is going to an end (I may still apply 
a few patches of refine). And the tests for it do help a lot in finding 
bugs and applying compatibility with RI, and special thanks to Stepan 
and "Support_Exec". :)
     However, I still have a problem with Support_Exec, it usually, if 
not always, meets a problem in loading kernel classes. Tracing into the 
code, I find it add a parameter "-Xbootclasspath:" to launcher with a 
System Property("com.ibm.oti.system.class.path", I'm using J9 for DRLVM 
not ready for jvmti yet). But the property was null on my workspace. 
After deleting that parameter, I get all tests pass using both Ant and 
eclipse. So can someone tell me how to handle this? Or can I make a 
little update to it?

      All existing tests has pass on both Harmony and RI in my 
workspace(Linux/windows) when make a little change to lib name. Though 
VM may not be updated for it very soon, I'd like to add tests to 
Harmony, make it excluded first until VM ready, in order that some one 
who is interested can check by making a little change and run tests. Any 
comments/suggestions?

-- 

Best Regards!

Jimmy, Jing Lv
China Software Development Lab, IBM

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message