harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Loenko" <mloe...@gmail.com>
Subject [classlib] HARMONY-820 (beautifying of java.beans classes)
Date Tue, 11 Jul 2006 04:28:16 GMT
Hi Alexei

Why do you think that your proposed style:
    public Object get(Object oldInstance) {
        ObjectNode node;
        Object result;

        if (oldInstance == null) {
            return null;
        }

        node = nodes.get(oldInstance);
        result = getValue(node);

        return result;
    }

is more transparent than original one:
    public Object get(Object oldInstance) {
        if(oldInstance == null) {
            return null;
        }

        ObjectNode node = (ObjectNode) nodes.get(oldInstance);
        Object result = getValue(node);
        return result;
    }


I'd rather change it something like this way:
    public Object get(Object oldInstance) {
        if(oldInstance == null) {
            return null;
        }

        return getValue( (ObjectNode) nodes.get(oldInstance) );
    }
At least I'd get rid of the 'result' variable


Thanks,
Mikhail

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message