harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geir Magnusson Jr <g...@pobox.com>
Subject Re: [general] hdk and jre for review...
Date Fri, 21 Jul 2006 11:54:51 GMT


Mikhail Fursov wrote:
> Have tested Windows version too.
> Eclipse3.1.1 runs OK, tested for Java and Plugin-development projects.
> Also I tried to run DeCapo benchmark:
> hsqldb, xalan, antlr, bloat, jython and ps: passed OK
> batik, pmd, fop: could not run (lack of experience)
> chart: failed with
> ERROR: Destructive unwinding: C++ objects detected on stack!
>  droping 0x05E8F518
> setting curr 0x05E8FF68
> java.lang.UnsatisfiedLinkError: Can not find the library: gl.dll
>        at java.lang.Runtime.loadLibrary0()
>        at java.lang.System.loadLibrary()
>        at org.apache.harmony.awt.gl.Surface.<clinit>(Surface.java:77)
>        at java.awt.image.BufferedImage.createImageSurface(
> BufferedImage.java:659)
>        at java.awt.image.BufferedImage.<init>(BufferedImage.java:352)
>        at com.lowagie.text.pdf.PdfGraphics2D.<init>()
>        at com.lowagie.text.pdf.PdfContentByte.createGraphics()
>        at dacapo.Graph.plotGraph()

Like I said in a note, no graphics support in win version.  I'll get
that in hopefully today, but note that it's still in transition.

> 
> 
> Not so bad for the first JRE snapshot which is "pre-alpha : not complete or
> compatible" :)

Indeed - we have a lot to be proud of.

geir

> 
> On 7/21/06, Alexey Varlamov <alexey.v.varlamov@gmail.com> wrote:
>>
>> Nathan,
>>
>> I've created corresponding JIRA and attached a quick-fix:
>> http://issues.apache.org/jira/browse/HARMONY-939
>>
>> -- 
>> Alexey
>>
>> 2006/7/21, Nathan Beyer <nbeyer@kc.rr.com>:
>> > I tried running Eclipse 3.2 on the Windows JRE build and it launches
>> the
>> > splash screen and the workspace selection dialog, but after you click
>> ok, it
>> > pukes and spits out the following to standard error.
>> >
>> > ERROR: Destructive unwinding: C++ objects detected on stack!
>> >  droping 0x05BDF430
>> >  setting curr 0x05BDFF68
>> >
>> > The Eclipse log is full of message about not being able to load certain
>> > classes. Here's the first exception stack trace. Also note the
>> > 'java.version' and 'java.vendor'; I presume we'll need to change those
>> > eventually.
>> >
>> > !SESSION 2006-07-21 00:00:08.362
>> > -----------------------------------------------
>> > eclipse.buildId=M20060629-1905
>> > java.version=11.2.0
>> > java.vendor=Intel DRL
>> > BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
>> >
>> > !ENTRY org.eclipse.osgi 4 0 2006-07-21 00:00:09.153
>> > !MESSAGE An error occurred while automatically activating bundle
>> > org.eclipse.core.runtime.compatibility (25).
>> > !STACK 0
>> > org.osgi.framework.BundleException: Exception in
>> > org.eclipse.core.internal.plugins.CompatibilityActivator.start() of
>> bundle
>> > org.eclipse.core.runtime.compatibility.
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator
>> (Bu
>> > ndleContextImpl.java:1014)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl.start
>> (BundleConte
>> > xtImpl.java:970)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
>> BundleHost.j
>> > ava:317)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.start
>> (AbstractBundle
>> > .java:256)
>> >        at
>> >
>> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.preFindLocalCla
>>
>> > ss(EclipseLazyStarter.java:86)
>> >        at
>> > org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass
>> (Classpat
>> > hManager.java:409)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass
>> (Defa
>> > ultClassLoader.java:188)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass
>> (BundleL
>> > oader.java:339)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:391)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:352)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass
>> (DefaultCl
>> > assLoader.java:83)
>> >        at java.lang.ClassLoader.loadClass()
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass
>> (BundleLoader
>> > .java:276)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(
>> BundleHost.jav
>> > a:227)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass
>> (AbstractBu
>> > ndle.java:1245)
>> >        at
>> >
>> org.eclipse.core.internal.runtime.CompatibilityHelper.getPluginDescriptor
>> (Co
>> > mpatibilityHelper.java:63)
>> >        at
>> > org.eclipse.core.runtime.Plugin.initializeDescriptor(Plugin.java:706)
>> >        at org.eclipse.core.runtime.Plugin.start(Plugin.java:692)
>> >        at
>> > org.eclipse.core.internal.runtime.PlatformActivator.start
>> (PlatformActivator.
>> > java:39)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run
>> (BundleConte
>> > xtImpl.java:995)
>> >        at java.security.AccessController.doPrivilegedImpl()
>> >        at java.security.AccessController.doPrivileged()
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator
>> (Bu
>> > ndleContextImpl.java:989)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl.start
>> (BundleConte
>> > xtImpl.java:970)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
>> BundleHost.j
>> > ava:317)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.resume
>> (AbstractBundl
>> > e.java:329)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(
>> Framework.ja
>> > va:1037)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles
>> (Sta
>> > rtLevelManager.java:573)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL
>> (StartLeve
>> > lManager.java:495)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel
>>
>> (S
>> > tartLevelManager.java:275)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent
>> (Sta
>> > rtLevelManager.java:455)
>> >        at
>> > org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent
>> (EventManager.
>> > java:189)
>> >        at
>> > org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run
>> (EventManage
>> > r.java:291)
>> > Caused by: java.lang.NoClassDefFoundError:
>> org/eclipse/core/runtime/Plugin
>> >        at java.lang.reflect.VMReflection.getMethodReturnType()
>> >        at java.lang.reflect.Method$MethodData.initReturnType()
>> >        at java.lang.reflect.Method.getReturnType()
>> >        at java.lang.Class$ReflectionData.isMethodMatches()
>> >        at java.lang.Class$ReflectionData.mergeMethods()
>> >        at java.lang.Class$ReflectionData.initPublicMethods()
>> >        at java.lang.Class.getMethod()
>> >        at
>> > org.eclipse.core.internal.runtime.CompatibilityHelper.setPlugin
>> (Compatibilit
>> > yHelper.java:48)
>> >        at
>> > org.eclipse.core.internal.plugins.CompatibilityActivator.start
>> (Compatibility
>> > Activator.java:23)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run
>> (BundleConte
>> > xtImpl.java:995)
>> >        at java.security.AccessController.doPrivilegedImpl()
>> >        at java.security.AccessController.doPrivileged()
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator
>> (Bu
>> > ndleContextImpl.java:989)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl.start
>> (BundleConte
>> > xtImpl.java:970)
>> >        ... 31 more
>> > Caused by: java.lang.ClassNotFoundException:
>> org.eclipse.core.runtime.Plugin
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:407)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:352)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass
>> (DefaultCl
>> > assLoader.java:83)
>> >        at java.lang.ClassLoader.loadClass()
>> >        at java.lang.reflect.VMReflection.getMethodReturnType()
>> >        ... 44 more
>> > Root exception:
>> > java.lang.NoClassDefFoundError: org/eclipse/core/runtime/Plugin
>> >        at java.lang.reflect.VMReflection.getMethodReturnType()
>> >        at java.lang.reflect.Method$MethodData.initReturnType()
>> >        at java.lang.reflect.Method.getReturnType()
>> >        at java.lang.Class$ReflectionData.isMethodMatches()
>> >        at java.lang.Class$ReflectionData.mergeMethods()
>> >        at java.lang.Class$ReflectionData.initPublicMethods()
>> >        at java.lang.Class.getMethod()
>> >        at
>> > org.eclipse.core.internal.runtime.CompatibilityHelper.setPlugin
>> (Compatibilit
>> > yHelper.java:48)
>> >        at
>> > org.eclipse.core.internal.plugins.CompatibilityActivator.start
>> (Compatibility
>> > Activator.java:23)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run
>> (BundleConte
>> > xtImpl.java:995)
>> >        at java.security.AccessController.doPrivilegedImpl()
>> >        at java.security.AccessController.doPrivileged()
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator
>> (Bu
>> > ndleContextImpl.java:989)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl.start
>> (BundleConte
>> > xtImpl.java:970)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
>> BundleHost.j
>> > ava:317)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.start
>> (AbstractBundle
>> > .java:256)
>> >        at
>> >
>> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.preFindLocalCla
>>
>> > ss(EclipseLazyStarter.java:86)
>> >        at
>> > org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass
>> (Classpat
>> > hManager.java:409)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass
>> (Defa
>> > ultClassLoader.java:188)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass
>> (BundleL
>> > oader.java:339)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:391)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:352)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass
>> (DefaultCl
>> > assLoader.java:83)
>> >        at java.lang.ClassLoader.loadClass()
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass
>> (BundleLoader
>> > .java:276)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(
>> BundleHost.jav
>> > a:227)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass
>> (AbstractBu
>> > ndle.java:1245)
>> >        at
>> >
>> org.eclipse.core.internal.runtime.CompatibilityHelper.getPluginDescriptor
>> (Co
>> > mpatibilityHelper.java:63)
>> >        at
>> > org.eclipse.core.runtime.Plugin.initializeDescriptor(Plugin.java:706)
>> >        at org.eclipse.core.runtime.Plugin.start(Plugin.java:692)
>> >        at
>> > org.eclipse.core.internal.runtime.PlatformActivator.start
>> (PlatformActivator.
>> > java:39)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run
>> (BundleConte
>> > xtImpl.java:995)
>> >        at java.security.AccessController.doPrivilegedImpl()
>> >        at java.security.AccessController.doPrivileged()
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator
>> (Bu
>> > ndleContextImpl.java:989)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleContextImpl.start
>> (BundleConte
>> > xtImpl.java:970)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
>> BundleHost.j
>> > ava:317)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.AbstractBundle.resume
>> (AbstractBundl
>> > e.java:329)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(
>> Framework.ja
>> > va:1037)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles
>> (Sta
>> > rtLevelManager.java:573)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL
>> (StartLeve
>> > lManager.java:495)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel
>>
>> (S
>> > tartLevelManager.java:275)
>> >        at
>> >
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent
>> (Sta
>> > rtLevelManager.java:455)
>> >        at
>> > org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent
>> (EventManager.
>> > java:189)
>> >        at
>> > org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run
>> (EventManage
>> > r.java:291)
>> > Caused by: java.lang.ClassNotFoundException:
>> org.eclipse.core.runtime.Plugin
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:407)
>> >        at
>> > org.eclipse.osgi.framework.internal.core.BundleLoader.findClass
>> (BundleLoader
>> > .java:352)
>> >        at
>> > org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass
>> (DefaultCl
>> > assLoader.java:83)
>> >        at java.lang.ClassLoader.loadClass()
>> >        at java.lang.reflect.VMReflection.getMethodReturnType()
>> >        ... 44 more
>> >
>> > > -----Original Message-----
>> > > From: Geir Magnusson Jr [mailto:geir@pobox.com]
>> > > Sent: Thursday, July 20, 2006 7:22 PM
>> > > To: harmony-dev@incubator.apache.org
>> > > Subject: Re: [general] hdk and jre for review...
>> > >
>> > > That's because I'm a moron and my userid is 'geirm'
>> > >
>> > > http://people.apache.org/~geirm/harmony
>> > >
>> > >
>> > > I'm uploading windows versions now.  Note they have no AWT/Swing
>> support
>> > > right now.
>> > >
>> > > geir
>> > >
>> > > Stefano Mazzocchi wrote:
>> > > > Geir Magnusson Jr wrote:
>> > > >> I have a HDK and JRE for linux on
>> > > >>
>> > > >>     http://people.apache.org/~geir/harmony
>> > > >
>> > > > I get a 404.
>> > > >
>> > >
>> > > ---------------------------------------------------------------------
>> > > Terms of use : http://incubator.apache.org/harmony/mailing.html
>> > > To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> > > For additional commands, e-mail:
>> harmony-dev-help@incubator.apache.org
>> >
>> >
>> > ---------------------------------------------------------------------
>> > Terms of use : http://incubator.apache.org/harmony/mailing.html
>> > To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> > For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>>
>>
> 
> 

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message