harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: [classlib] mem
Date Thu, 06 Jul 2006 18:01:23 GMT


Magnusson, Geir wrote:
>> -----Original Message-----
>> From: Tim Ellison [mailto:t.p.ellison@gmail.com] 
>> Sent: Thursday, July 06, 2006 12:34 PM
>> To: harmony-dev@incubator.apache.org
>> Subject: Re: [classlib] mem
>>
>> (sorry for the very late response)
>>
>> Geir Magnusson Jr wrote:
>>> I don't mind the macros, I just think the actual function should be
>>> named something different than the macro and have some docs to stem
>>> confusion from other readers in the future.
>>>
>>> Yea/nea?
>> Yea to doc (thanks!) and nea to renaming.  It is simple to find the
>> function once you know that they have the same name, and not hard to
>> mentally skip the first arg.
> 
> What's the downside of renaming?  There is no required relationship
> between the two...

"It is simple to find the function once you know that they have the same
name."

-- 

Tim Ellison (t.p.ellison@gmail.com)
IBM Java technology centre, UK.

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message