harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Shimansky <gshiman...@gmail.com>
Subject Re: how to build Harmony on Windows (with minimum of commercial soft)
Date Sat, 22 Jul 2006 21:57:20 GMT
On Sunday 09 July 2006 14:54 Thorbjørn Ravn Andersen wrote:
> Gregory Shimansky skrev  den 01-06-2006 23:34:
> > First I decided to use the current MS free software to repeat what is
> > done
> > by commercial. Nowdays MS offers VS.NET 2005 express edition (no earlier
> > verions are available for download as far as I could find) and
> > Platform SDK
> > Server 2003 R2 (at first I've downloaded an earlier one but later
> > upgraded
> > to 2006 year version). The VS 2005 brings some new nuisances which
> > software
> > written outside of Redmond wasn't ready for.
>
> I have now played a bit around with this, and I would like to have you
> confirm that the software above is the _ONLY_ Visual Studio stuff
> installed on your machine?
>
> The reason for this is that I have Visual Studio C++ Express, Platform
> Server 2003 SDK R2 (the latest I could find), and MASM installed on my
> XP box, and I cannot get a runnable deploy/.../jre/java.exe

(Sorry for a very late response, maybe it still may help you)

First I have to admit that I didn't try free MS toolchain since the time I 
wrote the email describing how I built classlib with it. At that time I 
thought that current free toolchain provided by MS is not really suitable and 
switched completely to Linux. I think many things could have changed in 
classlib but I assure you that all I had installed was Visual Studio Express 
and Platform SDK, not even MASM because it was not available by that time.

> If I run first the "C:\Program Files\Microsoft Platform SDK for Windows
> Server 2003 R2\SetEnv.cmd" /XP32 command and then the
> "C:\Program Files\Microsoft Visual Studio 8\VC\vcvarsall.bat" I can
> build all of classlib, but invoking deploy\jdk\jre\bin\java gives me the
> dreaded "Cannot find MSVCR8.DLL" dialogue box.

The library "MSVCR80.dll" is installed in windows\system directory for me so 
it has to be accessible to any applications. This is what objdump -x shows to 
me for java.exe compiled on uh... June 06... it's been quite a while since I 
actually used windows toolchain for classlib.

> I tried looking around on the net for information how to fix this, and
> changing -MD to -MT did not change anything.   All this with manifests
> and dll is very strange to me so I'm giving up on that for the moment.

I can understand you, I am not a big windows expert myself.

-- 
Gregory Shimansky, Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message