harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geir Magnusson Jr <geir.magnus...@runbox.com>
Subject Re: [classlib] odd problems when running tests under linux...
Date Fri, 16 Jun 2006 13:44:55 GMT
Excellent - do you think it's worthwhile goosing the version to v4?

geir

(testing an IMAP account - dont' respond to this email address directly...)



Oliver Deakin wrote:
> 
> Geir Magnusson Jr wrote:
>> Oliver Deakin wrote:
>>  
>>> geir@pobox.com wrote:
>>>    
>>>> I just got my ubuntu box setup, and when running the test suite, I see
>>>> this :
>>>>
>>>>     [junit] Exception in thread "main" java.lang.NoClassDefFoundError:
>>>> org.apache.harmony.luni.www.protocol.jar.JarURLConnection
>>>>         
>>> This package was renamed a while back. It's now
>>> org.apache.harmony.luni.internal.net.www.protocol.jar.JarURLConnection
>>> (!), and the
>>> latest J9 VME kernels have those changes reflected in their code, which
>>> leads me to
>>> think that you might have an old version of the kernel classes.
>>>     
>>
>>  
>>> Could you tell me if in your jre/bin/default directory there is a single
>>> kernel.jar
>>> or two jars, luni-kernel.jar and security-kernel.jar?
>>>     
>>
>> two.
>>
>> This is a brand new machine (it was an T42 running windows until about
>> 4pm yesterday), and it got v3 of the j9 vm yesterday... do I don't think
>> I "crossed the beams" - this is the only j9vm it's ever had.
>>   
> 
> Right, think Ive found the cause - looks like I mistakenly included a 
> version of com.ibm.oti.vm.VM.class
> in the kernel on Linux that had that old package name in (don't ask me 
> how - must have been a friday
> afternoon :( )
> 
> I have replaced the VME v3 for Linux on DeveloperWorks with a one that 
> contains the updated kernel.
> Please try this one and let me know how you get on - sorry for the 
> hassle caused.
> 
>> Doesn't anyone else see this?
>>   
> 
> I guess everyone else was still using the v2 and just moved the files 
> over - v2 had the correct
> package names in. Also, the Windows v3 contains the right package 
> references.
> 
> Thanks for finding this!
> 
> Regards,
> Oliver
> 
>> (thx)
>>
>> geir
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>>
>>
>>   
> 

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message