harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Gorr" <vvg...@gmail.com>
Subject Re: [drlvm] build fails on Windows os
Date Tue, 27 Jun 2006 08:09:24 GMT
On 6/27/06, Mark Hindess <mark.hindess@googlemail.com> wrote:
>
>
> On 27 June 2006 at 9:48, "Marina Goldburt" <marina.v.goldburt@gmail.com>
> wrote:
> >
> > On 6/27/06, Geir Magnusson Jr <geir@pobox.com> wrote:
> > >
> > > Odd.  It was broken for me too.  What changed?
> > >
> > > I applied the patch - thanks.
> >
> >  I think, the problem is in the log4cxx revision -
> > the old log4cxx didn't use the aprutil xml API.
>
> Ah ... this problem would be from my change as discussed in the recent
> "[DRLVM] building from svn on FC5" thread where I wrote:
>
> I've fixed (in r416807) the revisions for log4cxx on linux and windows
> to use r416779.  Works for me on Linux.  Can some test on windows and
> report if this causes any regression?
>
> Obviously it did cause a regression on windows but the new version is
> needed on Linux to get the build to work.
>
> I've backed out the windows part of this change in r417350.  Can someone
> check that this fixes the problem on windows?


Mark,


yes, the problem disappeared on Windows after your change.

Although, I don't understand why should we use the different revisions of
LOG4CXX on Windows and Linux?

If the patch mentioned by Marina is accepted then the problem also
disappears.

I'd like to hear your opinion.



Thanks,

Vladimir.

Regards,
> Mark.
>
>
>
>
>
>
>
>
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message