harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Shimansky <gshiman...@gmail.com>
Subject Re: [DRLVM] building from svn on FC5
Date Fri, 23 Jun 2006 18:13:06 GMT
On Friday 23 June 2006 19:55 Naveen Neelakantam wrote:
> They are the default Fedora Core 5 compiler versions (which I
> mentioned before, but neglected to post again.  sorry).
>
> ie. 4.1.0 20060304 (Red Hat 4.1.0-3).

I've installed gcc-4.1.1 on gentoo and got the same errors. It is probably one 
more move of gcc towards stricter C++ syntax interpretation.

I didn't want to figure out how to fix it, instead I just removed "-r 365029" 
from remote.LOG4CXX.archive URL in lnx.properties to see if the problem with 
log4cxx was already fixed in their svn. I've removed 
build/pre-copied/common/LOG4CXX, did another "build.sh update" and the ran 
build again. Voila, it worked!

So the problem with log4cxx is already fixed upstream in svn. I've ran 
build.sh test, I've tried to run specjvm98 with -Xtrace:classloader just to 
test logging and got the same results as yesterday. So it seems that logger 
is ok.

If you think this deserves JIRA I can certainly create one. But since I've 
just deleted revision switch for svn to download the latest log4cxx at some 
moment we may get regression instead of improvement. The revision which 
worked for me is 416779. Maybe we can temporarily switch to it. Certainly it 
is better to use releases which are already installed in the system.

> On Jun 23, 2006, at 4:47 AM, Geir Magnusson Jr wrote:
> > type
> >
> > $ gcc --version
> > $ g++ --version
> >
> > What versions are reported?
> >
> > Naveen Neelakantam wrote:
> >> Hello Geir,
> >>
> >> I downloaded a fresh copy of harmony from svn and got the same error.
> >>
> >> To be clear, these were my steps:
> >>> svn checkout https://svn.apache.org/repos/asf/incubator/harmony
> >>> cd harmony/enhanced/drlvm/trunk/build
> >>> chmod +x build.sh
> >>> ./build.sh update
> >>> ./build.sh
> >>
> >> And then I got the same error that I listed in my previous email:
> >>
> >> build.native.cpp:
> >>        [cc] 141 total files to be compiled.
> >>        [cc]
> >> /work/nneelaka/Sandbox/harmony/enhanced/drlvm/trunk/build/
> >> lnx_ia32_gcc_release/semis/extra/log4cxx/src/include/log4cxx/xml/
> >> domconfigurator.h:243:
> >> error: extra qualification 'log4cxx::xml::DOMConfigurator::' on
> >> member
> >> 'subst'
> >>        [cc]
> >> /work/nneelaka/Sandbox/harmony/enhanced/drlvm/trunk/build/
> >> lnx_ia32_gcc_release/semis/extra/log4cxx/src/include/log4cxx/
> >> helpers/unicodehelper.h:98:
> >> error: extra qualification 'log4cxx::helpers::UnicodeHelper::' on
> >> member
> >> 'lengthUTF8'
> >>        [cc]
> >> /work/nneelaka/Sandbox/harmony/enhanced/drlvm/trunk/build/
> >> lnx_ia32_gcc_release/semis/extra/log4cxx/src/include/log4cxx/
> >> helpers/unicodehelper.h:98:
> >> error: extra qualification 'log4cxx::helpers::UnicodeHelper::' on
> >> member
> >> 'lengthUTF8'
> >>        [cc]
> >> /work/nneelaka/Sandbox/harmony/enhanced/drlvm/trunk/build/
> >> lnx_ia32_gcc_release/semis/extra/log4cxx/src/include/log4cxx/xml/
> >> domconfigurator.h:243:
> >> error: extra qualification 'log4cxx::xml::DOMConfigurator::' on
> >> member
> >> 'subst'
> >>        [cc]
> >> /work/nneelaka/Sandbox/harmony/enhanced/drlvm/trunk/build/
> >> lnx_ia32_gcc_release/semis/extra/log4cxx/src/include/log4cxx/
> >> helpers/unicodehelper.h:98:
> >> error: extra qualification 'log4cxx::helpers::UnicodeHelper::' on
> >> member
> >> 'lengthUTF8'
> >>
> >> Previous threads led me to believe that this issue was resolved in
> >> JIRA.  Mark then committed the changes into svn, and things worked
> >> for a
> >> while.
> >>
> >> Thanks,
> >> Naveen
> >>
> >> On Jun 22, 2006, at 3:19 PM, Geir Magnusson Jr wrote:
> >>> Odd.  Nothing should have changed re log4cxx
> >>>
> >>> Sure nothing else changed?
> >>>
> >>> geir
> >>>
> >>> neelakan@uiuc.edu wrote:
> >>>> I just tried building DRLVM out of svn on FC5, and it has a
> >>>> build error that I've seen before.  This issue was resolved
> >>>> when I was using r413745, but now I am using r416471 and it
> >>>> is back.  The error is below:

Gregory Shimansky, Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message