harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Petrenko" <alexey.a.petre...@gmail.com>
Subject Re: Long,long testcase name...
Date Wed, 12 Apr 2006 12:24:12 GMT
Rules are good if you use them without fanaticism :)

So I think that it is good to include tested method signature in test
name. But it is OK to make them shorter in complicated cases.

I do not see any problem with not adding full package name to the
class name when it is obvious what class are you talking about.

2006/4/11, LvJimmy´╝îJing <firepure@gmail.com>:
> Hi all:
>    Following our testcase naming convention, I've find a name as: (hope it
> won't break your screen :))
> public void
> test_requestPasswordAuthentication_java_lang_String_java_net_InetAddress_int_java_lang_String_java_lang_String_java_lang_String_java_net_URL_java_net_Authenticator_RequestorType()
>    which is the testcase for
> java.net.Authenticator.requestPasswordAuthentication(
>            String rHost, InetAddress rAddr, int rPort, String rProtocol,
>            String rPrompt, String rScheme, URL rURL,
>            Authenticator.RequestorType reqType);
> and the class has another two method named requestPasswordAuthentication,
> and only this method take URL and RequestorType as its parameters.
>    The name is somehow too long to see and read, and I guess we can find a
> shorter one for it,
> e.g.test_requestPasswordAuthentication_URL_RequestorType. As URL and
> RequestorType can identify the exactly
> method to test. Or a adjusted naming convention shall be take. Any opinions?
> --
> Best Regards!
> Jimmy, Jing Lv
> China Software Development Lab, IBM

Alexey A. Petrenko
Intel Middleware Products Division
View raw message