harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stepan Mishura" <stepan.mish...@gmail.com>
Subject Re: [classlib][vm] Error running trunk builds and IBM VME v2
Date Wed, 12 Apr 2006 03:12:21 GMT
Hi Nathan,

Look to readme.txt: Troubleshooting & Known Problems

Thanks,
Stepan.


On 4/12/06, Nathan Beyer wrote:
>
> I think I had the appropriate changes, but I did do another update and
> build
> just in case and it still failed with the same message. Since the error
> message mentioned the JAVA_HOME environment variable, I looked and I did
> have it setup, but it was pointing to an alternate JRE, which I use for
> Ant
> and other Java tools. I then removed the JAVA_HOME variable and it worked
> perfectly fine.
>
> Is this expected behavior? I can log a bug report, but I thought I query
> the
> mailing list first.
>
> Thanks,
> -Nathan
>
> -----Original Message-----
> From: Mark Hindess [mailto:mark.hindess@googlemail.com]
> Sent: Tuesday, April 11, 2006 2:02 AM
> To: harmony-dev@incubator.apache.org
> Subject: Re: [classlib][vm] Error running trunk builds and IBM VME v2
>
> Hi Nathan,
>
> There were two separate commits for the renames for the new VME.  The
> second added the new String implementation.  I got the error you are
> seeing when I pulled the code between these two commits.  Do you still
> see this on a fresh checkout of latest trunk?
>
> Regards,
> Mark.
>
> On 4/11/06, Nathan Beyer <nbeyer@kc.rr.com> wrote:
> > I've been trying to run the latest code in the trunk with the IBM VME
> v2,
> > but I'm getting an error. I'm able to compile the entire classlib and
> native
> > libraries on Windows just fine and then paste the IBM VME distribution
> over
> > the 'deploy' folder. Every time I try to run a Java class I get an error
> > about the String class missing.
> >
> >
> >
> > Here's the exact error message I'm getting:
> >
> >
> >
> > JVMJ9VM019E Fatal error: Unable to find and initialize required class
> > java/lang/String
> >
> > JVMJ9VM020I Searched in C:\Documents and
> >
> Settings\Nathan\Desktop\Harmony\trunk\deploy\jre\bin\default\luni-
> kernel.jar
> >
> > JVMJ9VM020I Searched in C:\Documents and
> >
>
> Settings\Nathan\Desktop\Harmony\trunk\deploy\jre\bin\default\security-kernel
> > .jar
> >
> > JVMJ9VM023I This may indicate that JAVA_HOME is incorrect, or that class
> > libraries are not installed
> >
> >
> >
> > Since the String class moved to luni, which is in the 'jre/lib/boot'
> folder,
> > the VM won't find it in the luni-kernel or security-kernel JARs. Is
> there
> > just something that I'm missing in setting up the classlib with the IBM
> VME?
> > Any thoughts?
> >
> >
> >
> > Thanks,
> >
> > -Nathan
> >
> >
> >
>
>
> --
> Mark Hindess <mark.hindess@googlemail.com>
> IBM Java Technology Centre, UK.
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>


--
---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org

Thanks,
Stepan Mishura
Intel Middleware Products Division

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message