harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paulex Yang <paulex.y...@gmail.com>
Subject Re: [classlib] Testing
Date Thu, 27 Apr 2006 10:17:18 GMT
Geir Magnusson Jr wrote:
>
>
> Paulex Yang wrote:
>> Mikhail Loenko wrote:
>>> If it's separated, I'm OK with it
>>>
>>> Can you suggest dir names?
>>>   
>> Great!
>>
>> Either boot or injected(as Mark said) sounds good keyword to me.  so 
>> it can be one of below:
>> 1. src/test.injected/
>> 2. src/test/injected
>> 3. src/test.boot/
>> 4. src/test/boot
>>
>> Mmm...seems injected is more self-descriptive,  I prefer option 1. So 
>> the layout would be:
>> src/main
>> src/test
>> src/test.injected
>>
>> ideas?
>
> I suggest keeping "." chars out of pathnames....
no problem. I agree.
>
> Also, why "injected"?  Aren't there more functional names like "spec" 
> or "public" or "implementation" ?
IIRC we have proposed impl/internal as counterpart of "api" in this 
thread, but didn't reach agreement yet (each got someone's objection for 
some reasons). Really hard to make everyone happy:(.


>
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>


-- 
Paulex Yang
China Software Development Lab
IBM



---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message