harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geir Magnusson Jr <g...@pobox.com>
Subject Re: Long,long testcase name...
Date Tue, 11 Apr 2006 10:10:38 GMT


Paulex Yang wrote:
> Geir Magnusson Jr wrote:
>> testRequestPasswordAuthentication1()
>>
>> I mean, why do we want to embed all that crap in the testcase name?  
>> Who cares?  The only person that will care is someone fixing when a 
>> testcase breaks, and they'll read the code...
>>
> IMHO, the information is also useful when someone want to do some work 
> like upgrade, he may need to know if there is any test cases for the 
> requestPasswordAuthention(blabla...). But I agree that the current 
> naming convention almost lost its value because it is so difficult for 
> human reading. Maybe this information can be provided in other ways, 
> like annotation.

Upgrade what?  I think that this is a one-off kind of check people will 
do - if you want to know coverage for   <Class>.<method>(<args>) you 
will ... search for it? :)

What would an annotation do for you?

geir

>> geir
>>
>>
>> LvJimmy´╝îJing wrote:
>>> Hi all:
>>>
>>>     Following our testcase naming convention, I've find a name as: 
>>> (hope it
>>> won't break your screen :))
>>> public void
>>> test_requestPasswordAuthentication_java_lang_String_java_net_InetAddress_int_java_lang_String_java_lang_String_java_lang_String_java_net_URL_java_net_Authenticator_RequestorType()

>>>
>>>     which is the testcase for
>>> java.net.Authenticator.requestPasswordAuthentication(
>>>             String rHost, InetAddress rAddr, int rPort, String 
>>> rProtocol,
>>>             String rPrompt, String rScheme, URL rURL,
>>>             Authenticator.RequestorType reqType);
>>> and the class has another two method named 
>>> requestPasswordAuthentication,
>>> and only this method take URL and RequestorType as its parameters.
>>>     The name is somehow too long to see and read, and I guess we can 
>>> find a
>>> shorter one for it,
>>> e.g.test_requestPasswordAuthentication_URL_RequestorType. As URL and
>>> RequestorType can identify the exactly
>>> method to test. Or a adjusted naming convention shall be take. Any 
>>> opinions?
>>>
>>> -- 
>>>
>>> Best Regards!
>>>
>>> Jimmy, Jing Lv
>>> China Software Development Lab, IBM
>>>
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>>
>>
> 
> 

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message