harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paulex Yang <paulex.y...@gmail.com>
Subject Re: Long,long testcase name...
Date Tue, 11 Apr 2006 02:59:10 GMT

LvJimmy´╝îJing wrote:
> Hi all:
>     Following our testcase naming convention, I've find a name as: (hope it
> won't break your screen :))
> public void
> test_requestPasswordAuthentication_java_lang_String_java_net_InetAddress_int_java_lang_String_java_lang_String_java_lang_String_java_net_URL_java_net_Authenticator_RequestorType()
I don't mind if you missed one string or so....because I cannot read it....
>     which is the testcase for
> java.net.Authenticator.requestPasswordAuthentication(
>             String rHost, InetAddress rAddr, int rPort, String rProtocol,
>             String rPrompt, String rScheme, URL rURL,
>             Authenticator.RequestorType reqType);
> and the class has another two method named requestPasswordAuthentication,
> and only this method take URL and RequestorType as its parameters.
>     The name is somehow too long to see and read, and I guess we can find a
> shorter one for it,
In fact I also don't know why it is so necessary to include package name 
in the test method name. The class name only should be enough in 
99%(even more I guess) cases.
> e.g.test_requestPasswordAuthentication_URL_RequestorType. As URL and
> RequestorType can identify the exactly
> method to test. Or a adjusted naming convention shall be take. Any opinions?
I'm not sure if this is a good idea, how about if a new method 
requestPasswordAuthentication(URL, Authenticator) is introduced in Java 
6? (yes, yes, I know, it's just an assumption.)
> --
> Best Regards!
> Jimmy, Jing Lv
> China Software Development Lab, IBM

Paulex Yang
China Software Development Lab

Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org

View raw message