harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leo Simons <m...@leosimons.com>
Subject Re: Long,long testcase name...
Date Wed, 12 Apr 2006 13:36:09 GMT
On Wed, Apr 12, 2006 at 08:09:41PM +0700, Mikhail Loenko wrote:
> 2006/4/12, Andrew Zhang <zhanghuangzhu@gmail.com>:
> > Hello, geir,
> > Let's consider the case you mentioned.
> > I totally agree that "testRequestPasswordAuthentication1" is a BAD name,
> Why?

There's a whole "movement" devoted to answering that question :-)


might be of interest. "1" implies there is a "2", but what is the difference
between "1" and "2"?

Trying at every point along the way to make code as readable and descriptive
as possible is good. Eg


So you end up with names such as




they are painful to type, but less painful than typing javadocs, and more
likely to get read than javadocs, and likely to get read a lot more than
written. Furthermore, if you have camel case searching, you can search for
tRPA and get all the relevant bits.


Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org

View raw message