harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Loenko" <mloe...@gmail.com>
Subject Re: build problems
Date Fri, 03 Mar 2006 10:06:25 GMT
Thanks that helped.

The reason was: misconfiguration of Eclipse - I've uploaded workspace
and misconfigured Eclipse so it compiled the java sources and put
the classes into the same folder as sources. Those classes contained
wrong packages. At that time I have not even noticed that Eclipse compiled
something.

Then 'copy-resources' target from the Harmony build copied all those
class files into bin/ directory and javac got crazy.


BTW the build was modified and now it runs clean every time.
I'm not sure it is very good. Moreover that clean reports problems
like 'Could not find ...'; these problems do not break the build but
make me nervous about whether the build result is valid.

Thanks,
Mikhail

2006/3/2, Alexey Petrenko <alexey.a.petrenko@gmail.com>:
> > How can I fugure out which javac is used? JAVA_HOME points to JDK1.5 (have
> > tried 1.4 also - same result)
> Try ant -verbose it prints out a lot of info...
> --
> Alexey A. Petrenko
> Intel Middleware Products Division
>

Mime
View raw message