harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weldon Washburn" <weldon...@gmail.com>
Subject [jchevm] problems with gnu classpath and also jchevm builds
Date Sun, 26 Feb 2006 02:29:11 GMT
Archie, Ivan,

I am following the email that Ivan Snowdosker sent on Monday, Feb 20
that describes how to build and run JCHEVM.  I have hit a couple of
bewildering snags.  I installed the latest version of cygwin from the
net but there still seems to be build problems.

I need to build classpath-0.20 to get the native methods. 
"./configure --with-jikes --enable-jni" seems to run OK.  But when I
type, "make" for classpath-0.20, it somehow sets "top_srcdir=.."
instead of "top_srcdir=."   The Makefile sets it to "top_srcdir=." but
it somehow gets reset to "..".   I can't find where it gets reset.

Since all I really need is the native methods,  I worked around the
above  by  doing a "cd ./native" then did a "make".  It looks like I
generated all the needed DLL's.

Next, I tried to configure JCHEVM.  I think the top-level directory is
supposed to have a "configure" file.  Its not there.  I did an "svn
update jchevm".  It shows, "At revision 381045."  But still no
"configure" file.  I have svn version 1.3.0 installed.

Any suggestions would be welcome.

Thanks


--
Weldon Washburn
Intel Middleware Products Division

Mime
View raw message