harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrico Migliore <enrico.migli...@fatti.com>
Subject Re: [jchevm] problems with gnu classpath and also jchevm builds
Date Mon, 27 Feb 2006 15:20:47 GMT
snowdosker wrote:

>
>>> Archie, Ivan,
>>>
>>> I am following the email that Ivan Snowdosker sent on Monday, Feb 20
>>> that describes how to build and run JCHEVM.  I have hit a couple of
>>> bewildering snags.  I installed the latest version of cygwin from the
>>> net but there still seems to be build problems.
>>>
>>> I need to build classpath-0.20 to get the native methods. 
>>> "./configure --with-jikes --enable-jni" seems to run OK.  But when I
>>> type, "make" for classpath-0.20, it somehow sets "top_srcdir=.."
>>> instead of "top_srcdir=."   The Makefile sets it to "top_srcdir=." but
>>> it somehow gets reset to "..".   I can't find where it gets reset.
>>
>>
> Yes, I was also surprized by such behaviour.
> This was with jikes downloaded and installed from cygwin site.
> If I remember right the problem magically gone when I got jikes sources
> from here
> http://prdownloads.sourceforge.net/jikes/jikes-1.22.tar.bz2?download
> and build jikes from sources after applying this patch
> http://sourceforge.net/tracker/index.php?func=detail&aid=1202863&group_id=128803&atid=712760

>
>
> Ivan

Hi Ivan,

 I confirm that.
 In order to proceed, one must apply the patch you mention to Jikes.

Enrico
 

Mime
View raw message