harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From e.@eldiablo.co.uk
Subject Re: Subversion problems?
Date Tue, 17 Jan 2006 17:40:41 GMT
Ok guys thanks for the responses.

Geir, George, your right I think, definitely looks like something my end
now! I was using https://svn.apache.org/repos/asf/incubator/harmony as the
url for my working copy, and the problems I am having are using the svn
command line client (v1.2.3, r15833) on Mac OS X. Since you guys said you
weren't having problems, I tried checking out the classlib from a
dedicated server I've got running FC3 and svn command line client v1.3.0
(r17949), and it seems to be working fine!

Leo, comments inline (apologies for any bad formatting, using webmail):

> On Tue, Jan 17, 2006 at 05:00:56PM -0000, el@eldiablo.co.uk wrote:
>> Hi guys,
>>
>> I've just tried updating my Harmony tree from Subversion, but I'm
>> getting
>> this error:
>>
>> svn: SSL is not supported
>
> This means your svn client was compiled without SSL support (or the webdav
> lib that svn uses, neon, was compiled without SSL support).

Aha, makes sense - I compiled from scratch anyway on this machine, so
it'll be easy enough to re-comp with SSL support, thanks for figuring out
that one :-)

>
>> So then I decided to specifically look at Tim's instructions from
>> yesterday for building the classlib snapshots, and so tried the
>> following
>> svn command:
>>
>> svn checkout -r HEAD
>> https://svn.apache.org/repos/asf/incubator/harmony/enhanced/classlib/trunk
>> Harmony
>>
>> However this resulted in the same error message...
>>
>> I then tried doing a checkout without using SSL (just standard http) but
>> it keeps hanging, occasionally quitting complaining of chunk errors or
>> write locks :-(
>
> a chunk error is likely a TCP/IP problem. Sounds like your connection to
> the ASF svn server is a bit flakey. When you get a write lock error you
> can run 'svn cleanup' on your local copy, then do 'svn up' of that copy
> over and over again (running 'svn cleanup' several times perhaps, or rm
> -Rf
> broken parts of the working copy) until you get everything.
>

Hmm, that's useful information too - as I had made no changes to my
working copy, I decided a rm -Rf of the entire thing, and a re-attempt at
checking out was in order, but maybe 'svn cleanup' and 'svn update' might
be more useful in future :-)

>> Now the problem could be at my end, and dare I say it the problem might
>> just be I'm being stupid, but can someone just try updating their local
>> tree or doing a checkout to see if there are any problems at the minute?
>
> At
>
>   http://monitoring.apache.org/status/
>
> you can see whether any particular service is down. SVN has held up pretty
> well over the last few weeks...Gems of info like this are at
> http://www.apache.org/dev/ :-)

Ah good stuff, I'll consult this in future cases.

>
> If the problem persists, you might want to consider trying to use svk for
> maintaining your working copy:
>
>  http://svk.elixus.org/
>
> I've heard reports that its a little better at dealing with HTTP / TCP
> worries.

Interesting, I'd briefly looked at it, but nothing in detail. I might give
it a try.

>
> cheers!
>
> LSD
>
>

Thanks for your help guys, I'm off to shoot my Mac, then re-compile
Subversion!

Cheers,
Elliott



Mime
View raw message