harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Loenko, Mikhail Y" <mikhail.y.loe...@intel.com>
Subject RE: Experiments building security2
Date Fri, 13 Jan 2006 11:57:05 GMT
That is really good news. For the remaining issues we will try to
reproduce them and provide a fix.

The next steps could be:
1. Closing the issue with Javadocs and updating the sources according to
the decision. (There might be both short-term and long-term decisions,
like remove tags and provide something else)
2. Resolving
http://mail-archives.apache.org/mod_mbox/incubator-harmony-dev/200512.mb
ox/%3cOF72152DF1.492D3A31-ON802570CE.00371BE2-802570CE.003B501F@uk.ibm.c
om%3e
3. Renaming com.openintel packages to whatever we decide
4. Binding Jar verification to security2
5. Selecting one of Base64 de/encoders and ASN.1 de/encoders
6. Something else

Please let me know where my help would be useful.

Thanks,
Mikhail Loenko
Intel Middleware Products Division

>-----Original Message-----
>From: Tim Ellison [mailto:t.p.ellison@gmail.com]
>Sent: Thursday, January 12, 2006 8:30 PM
>To: harmony-dev
>Subject: Experiments building security2
>
>FYI I just tried using the Harmony classlib code (and IBM VM) to build
>'security2' with the existing security2 build scripts.
>
>With a minor tweak(*) to the security2/make/build.xml to reflect the
>layout of our deployment, I was able to successfully build security2
>using only the class library code from Harmony.
>
>This is good news, since it shows that the security2 component will fit
>into the existing classlib builds and maintain our 'self-hosting'
status
>(i.e. no dependencies on another Java implementations after the initial
>bootstrap build).
>
>This is what I ran:
>
>set HY_DEPLOY=/harmony/enhanced/classlib/trunk/deploy
>set HY_LIB=%HY_DEPLOY%/jre/lib/boot
>set ANT_HOME=/apache-ant-1.6.5
>set CLASSPATH=%HY_LIB%/kernel-stubs.jar;%HY_LIB%/luni.jar
>set INCLUDE=%HY_DEPLOY%/include;%INCLUDE%
>
>%HY_DEPLOY%\jre\bin\java.exe -cp %ANT_HOME%/lib/ant-launcher.jar
>-Dant.home=%ANT_HOME%/lib/ant-launcher.jar
>org.apache.tools.ant.launch.Launcher -lib %ANT_HOME%/lib
>-Dbuild.compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>
>
>and it all built successfully :-)
>
>I couldn't run the test suites (the junit fork fails) so still playing
>with that.
>
>
>(*) Minor tweak was adding /boot to the end of the jre/lib directory
>
>
>Index: build.xml
>===================================================================
>--- build.xml   (revision 367403)
>+++ build.xml   (working copy)
>@@ -298,7 +298,7 @@
>             <patternset refid="api.src.all"/>
>             <bootclasspath>
>                 <pathelement path="${build.path}/classes"/>
>-                <fileset dir="${java.home}/lib">
>+                <fileset dir="${java.home}/lib/boot">
>                     <include name="*.jar"/>
>                 </fileset>
>             </bootclasspath>
>
>
>
>
>--
>
>Tim Ellison (t.p.ellison@gmail.com)
>IBM Java technology centre, UK.

Mime
View raw message