harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Hindess (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-6640) UTF8 decoder doesn't properly decode supplementary characters
Date Tue, 14 Sep 2010 20:57:34 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-6640?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12909448#action_12909448
] 

Mark Hindess commented on HARMONY-6640:
---------------------------------------

I was thinking the same thing particularly when I was attaching the luni.jar  to the other
JIRA.  (Unfortunately the hudson slave that builds harmony is offline otherwise I'd have suggested
you use jar from there as luni.jar happens to be platform independent.)


> UTF8 decoder doesn't properly decode supplementary characters
> -------------------------------------------------------------
>
>                 Key: HARMONY-6640
>                 URL: https://issues.apache.org/jira/browse/HARMONY-6640
>             Project: Harmony
>          Issue Type: Bug
>          Components: Classlib
>    Affects Versions: 5.0M14
>         Environment: Windows Vista
>            Reporter: Robert Muir
>            Assignee: Tim Ellison
>             Fix For: 5.0M16
>
>         Attachments: HARMONY-6640.patch, HARMONY-6640.patch, nio_char.jar
>
>
> When attempting to build Lucene, I discovered a problem with UTF8 decoding.
> (this actually prevents our tests from even compiling without a workaround)
> For any codepoint > 0xffff (4-byte utf-8 sequence), the decoder doesn't properly
> split the decoded codepoint into surrogate pairs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message