harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-6640) UTF8 decoder doesn't properly decode supplementary characters
Date Tue, 14 Sep 2010 14:40:33 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-6640?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12909269#action_12909269
] 

Robert Muir commented on HARMONY-6640:
--------------------------------------

bq. Can you retest Lucene and see how it goes now? I can send you an updated "nio_char.jar"
if required.

Absolutely! if you can send me the jar, that would be extremely helpful, because I'm not setup
to build 
harmony on my platform (windows)...

This fix would get us much further in the testing process, and allow us to fix test failures
on harmony that 
are really our fault ("sunisms", etc).

By the way, I created LUCENE-2630 to track some of this.


> UTF8 decoder doesn't properly decode supplementary characters
> -------------------------------------------------------------
>
>                 Key: HARMONY-6640
>                 URL: https://issues.apache.org/jira/browse/HARMONY-6640
>             Project: Harmony
>          Issue Type: Bug
>          Components: Classlib
>    Affects Versions: 5.0M14
>         Environment: Windows Vista
>            Reporter: Robert Muir
>            Assignee: Tim Ellison
>             Fix For: 5.0M16
>
>         Attachments: HARMONY-6640.patch, HARMONY-6640.patch
>
>
> When attempting to build Lucene, I discovered a problem with UTF8 decoding.
> (this actually prevents our tests from even compiling without a workaround)
> For any codepoint > 0xffff (4-byte utf-8 sequence), the decoder doesn't properly
> split the decoded codepoint into surrogate pairs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message