harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-6529) [jdktools]hdk javac only support compliance 1.5
Date Sun, 30 May 2010 20:01:36 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-6529?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12873477#action_12873477
] 

Nathan Beyer commented on HARMONY-6529:
---------------------------------------

What's the issue? If you're trying to compile 1.6 source or target, this won't work with the
HDK5 code. If you're doing that with HDK6, then we probably do need to adjust the compliance
level to '-1.6' for that branch.

> [jdktools]hdk javac only support compliance 1.5
> -----------------------------------------------
>
>                 Key: HARMONY-6529
>                 URL: https://issues.apache.org/jira/browse/HARMONY-6529
>             Project: Harmony
>          Issue Type: Bug
>         Environment: All
>            Reporter: Li Jing Qin
>            Priority: Minor
>         Attachments: HARMONY-6529.diff
>
>
> In jdktools/modules/jdktools/src/main/java/org/apache/harmony/tools/javac/Main.java,
we are add '-1.5' as the compliance level. This will override any specify level which given
by the user. For example, javac -source 1.6 -target 1.6 will report unsupport. A simply change
'-1.5' to '-1.7' will solve this problem. From the page http://help.eclipse.org/help33/index.jsp?topic=/org.eclipse.jdt.doc.isv/guide/jdt_api_compile.htm,
we can find jdt compiler supports '-1.7'.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message