harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "deven you (JIRA)" <j...@apache.org>
Subject [jira] Created: (HARMONY-6460) [classlib][fdlibm]Upgrade fdlibm5.2 to 5.3
Date Wed, 03 Mar 2010 08:09:27 GMT
[classlib][fdlibm]Upgrade fdlibm5.2 to 5.3
------------------------------------------

                 Key: HARMONY-6460
                 URL: https://issues.apache.org/jira/browse/HARMONY-6460
             Project: Harmony
          Issue Type: Improvement
          Components: Classlib
    Affects Versions: 5.0M14
            Reporter: deven you
             Fix For: 5.0M14


Hi All,
I noticed that java spec says "The Java math library is defined with respect to fdlibm version
5.3." within java.lang.StrictMath class specification from jdk 5.0. However our harmony still
use fdlibm5.2. And a test case[1] shows harmony's math functions results are different compared
to ri 6.0 for this reason.
 So I think we should upgrade fdlibm from 5.2 to 5.3 to keep consistency with ri. I have done
this on my local machine by following steps:
1. Download fdlibm5.3 zip file from http://www.validlab.com/software/
2. Unzip the zip file, this will unzip a folder named fdlibm53 on current path. Then enter
fdlibm53 and rename fdlibm.h, Makefile, Makefile.in and s_lib_version.c with suffix .orig.
3. Re package all files in fdlibm53 into fdlibm_5.3.zip.
4. Replace HYROOT/deploy/oss/fdlibm_5.2.zip with the above fdlibm_5.3.zip, HYROOT is the root
directory of harmony classlib trunk repository.
5. Apply attached patch[2].
6. Build the trunk and run corresponding test case. 
[1][2]: see the attached files

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message