harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Deakin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-6330) [java6] version string shows java version as 1.5 in the 1.6 build
Date Wed, 17 Feb 2010 11:53:27 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-6330?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12834743#action_12834743
] 

Oliver Deakin commented on HARMONY-6330:
----------------------------------------

I just ran "java -version" on our java6 federated build and I now get:

Apache Harmony Launcher : (c) Copyright 1991, 2009 The Apache Software Foundation or its licensors,
as applicable.
java version "1.5.0"
Apache Harmony (1.6.0)
DRLVM (11.2.0)
pre-alpha : not complete or compatible
svn = r910876, (Feb 17 2010), Windows/ia32/msvc 1310, release build
http://harmony.apache.org

which is close but not quite there. For one thing, I assume we need to update the copyright
to 2010. We also still print java version 1.5.0 which is clearly wrong. The rest looks pretty
good now.

System properties are:
java.version=1.5.0
java.runtime.version=1.6.0
java.specification.version=1.6

The -version output gets the java version from java.version, so fixing that should resolve
both. I think the copyright statement is just hardcoded in the launcher - I'll take a quick
look.

> [java6] version string shows java version as 1.5 in the 1.6 build
> -----------------------------------------------------------------
>
>                 Key: HARMONY-6330
>                 URL: https://issues.apache.org/jira/browse/HARMONY-6330
>             Project: Harmony
>          Issue Type: Bug
>         Environment: 6.0M1 candidate (r809832)
>            Reporter: Tim Ellison
>            Priority: Minor
>             Fix For: 6.0M1
>
>
> The version string printed by the 6.0 build still declares that it implements java version
1.5,
> > java -version
> Apache Harmony Launcher : (c) Copyright 1991, 2009 The Apache Software Foundation or
its licensors, as applicable.
> java version "1.5.0"
> Apache Harmony (1.5.0)
> DRLVM (11.2.0)
> pre-alpha : not complete or compatible
> svn = r809832, (Sep  2 2009), Windows/ia32/msvc 1310, release build
> http://harmony.apache.org
> and the system properties are also misleading
> java.version=1.5.0
> java.runtime.version=1.5.0
> java.specification.version=1.5

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message