harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chunrong lai (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HARMONY-6062) [buildtest][eut] Can not run rut35 with Harmony
Date Fri, 26 Dec 2008 02:20:46 GMT

     [ https://issues.apache.org/jira/browse/HARMONY-6062?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

chunrong lai updated HARMONY-6062:
----------------------------------

    Attachment: org.eclipse.jdt.text.tests.JdtTextTestSuite.error.txt


 There are several observed exceptions as listed below, hopefully fixing one can fix others.

!MESSAGE Missing imported package org.eclipse.jdt.internal.compiler.tool_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-12-25 22:31:17.828
!MESSAGE Bundle org.eclipse.jdt.compiler.tool_1.0.100.v_922 [99] was not resolved.
!SUBENTRY 2 org.eclipse.jdt.compiler.tool 2 0 2008-12-25 22:31:17.828
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6

!STACK 1
java.lang.RuntimeException: Application "org.eclipse.test.uitestapplication" could not be
found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.ant.ui.antRunner,
org.eclipse.equinox.app.error, 
......

Root exception:
java.lang.ExceptionInInitializerError
	at org.eclipse.equinox.internal.provisional.p2.metadata.MetadataFactory.<clinit>(MetadataFactory.java:182)

Root exception:
java.lang.NoClassDefFoundError: org/eclipse/equinox/internal/provisional/p2/metadata/MetadataFactory
	at org.eclipse.equinox.internal.p2.metadata.repository.io.MetadataParser$UpdateDescriptorHandler.<init>(MetadataParser.java:750)


> [buildtest][eut] Can not run rut35 with Harmony
> -----------------------------------------------
>
>                 Key: HARMONY-6062
>                 URL: https://issues.apache.org/jira/browse/HARMONY-6062
>             Project: Harmony
>          Issue Type: Bug
>          Components: build - test - ci
>    Affects Versions: 5.0M8
>         Environment: Win32
>            Reporter: chunrong lai
>         Attachments: org.eclipse.jdt.text.tests.JdtTextTestSuite.error.txt
>
>
> hi, Colleagues:
>      When I run Eclipse Unit Test 3.5 suite with Harmony I met some exceptions while
RI runs fine here.  I am not sure if others met this issue also.
>      I am attaching the output file. In my understanding Harmony has strict constrains
for the jar files so I can see some error info like "!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment:
JavaSE-1.6".
>      To reproduce this issue,  one can do below steps to run selective test (here is
jdttext):
>        (1) Unzip eclipse-Automated-Tests-3.5M3.zip in root directory of some drives,
for example d:\.
>        (2) cd eclipse-testing, unzip eclipse-junit-tests-I20081030-1917.zip, unzip eclipse-SDK-3.5M3-win32.zip
>        (3) java -jar eclipse\plugins\org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
-application org.eclipse.test.uitestapplication -data workspace -dev bin formatter=org.apache.tools.ant.taskdefs.optional.junit.XMLJUnitResultFormatter,d:\eclipse-testing\eclipse\org.eclipse.jdt.text.tests.JdtTextTestSuite.xml
-testPluginName org.eclipse.jdt.text.tests -className org.eclipse.jdt.text.tests.JdtTextTestSuite
-os win32 -ws win32 -arch x86
>       In my running RI is OK with above steps while Harmony is not. 
>      

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message