harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Harmony Wiki] Update of "DevConfiguration Ubuntu8-04" by senakafdo
Date Mon, 19 May 2008 10:45:25 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Harmony Wiki" for change notification.

The following page has been changed by senakafdo:
http://wiki.apache.org/harmony/DevConfiguration_Ubuntu8-04

New page:
= Configuring Ubuntu 8.04 LTS (Hardy Heron) For Harmony Development =

These instructions presume a fresh install of Ubuntu 8.04 LTS (although should work with other
versions)
and that you have the ability to '''sudo''' or become the root (Super User).
These instructions should work on both x86 and x86_64.

1) Install subversion, gcc, g++ and make:

{{{
$ sudo apt-get install subversion
$ sudo apt-get install gcc
$ sudo apt-get install g++
$ sudo apt-get install make
}}}

2) Check whether Java is installed on your system.

{{{
$ java -version
}}}

Should print something similar to :

{{{
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) Client VM (build 10.0-b22, mixed mode, sharing)
}}}

If Java is installed, please proceed to step 4.

3) Install java : (1.6.0_06 or later from sun) : get from http://java.sun.com/  and install
as you see fit. 

 * Optionally you may install it as,

{{{
$ sudo apt-get install sun-java6-jdk
}}}

When done, the following should do the right thing in a shell : 

{{{
$ java -version
}}}

Should print something similar to :

{{{
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) Client VM (build 10.0-b22, mixed mode, sharing)
}}}

4) Install ant (1.7.0) : 

{{{
$ sudo apt-get install ant
}}}

When done, the following should do the right thing in a shell : 

{{{
$ ant -version
}}}

Should print something similar to :

{{{
Apache Ant version 1.7.0 compiled on August 29 2007
}}}

5) Install the '''ant-optional''' package

{{{
$ sudo apt-get install ant-optional
}}}

6) Get junit and drop the junit-X.jar into ant/lib (where X is the version of JUnit) '''[OPTIONAL]'''

7) Install AWT/Swing deps

{{{
$ sudo apt-get install liblcms1-dev
$ sudo apt-get install libpng12-dev
$ sudo apt-get install libjpeg62-dev
$ sudo apt-get install libx11-dev
$ sudo apt-get install libxft-dev
$ sudo apt-get install binutils-dev
$ sudo apt-get install libxml2-dev
$ sudo apt-get install libxtst-dev
}}}

Now you can continue with the build instructions as found at 
http://harmony.apache.org/quickhelp_contributors.html

'''NOTE''' :

 * You might require setting the ANT_OPTS environment variable

{{{
export ANT_OPTS='-Xms256m -Xmx512m'
}}}

 * You might have to copy the '''ecj_3.3.jar''' into the ant/lib

  1) First change directory to, common_resources/depends/jars/ecj_3.3

  {{{
$ cd common_resources/depends/jars/ecj_3.3
  }}}

  2) Copy '''ecj_3.3.jar''' into the ant/lib

  {{{
$ sudo cp ecj_3.3.jar /usr/share/ant/lib/
  }}}

 *  Optionally, you may copy the '''ecj_3.3.jar''' to '''~/.ant/lib''', which will not require
'''sudo''' privileges.
 You will have to create .ant/lib inside your '''home''' folder, if you don't already have
it.

  {{{
$ cp ecj_3.3.jar ~/.ant/lib/
  }}}

 This will help users who want to use '''ecj_3.3.jar''' for a single login.

Mime
View raw message