harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Pervov (JIRA)" <j...@apache.org>
Subject [jira] Created: (HARMONY-5466) [classlib][util] display language is reset to the value of constructor after Locale is set as default.
Date Wed, 06 Feb 2008 13:01:49 GMT
[classlib][util] display language is reset to the value of constructor after Locale is set
as default.
------------------------------------------------------------------------------------------------------

                 Key: HARMONY-5466
                 URL: https://issues.apache.org/jira/browse/HARMONY-5466
             Project: Harmony
          Issue Type: Bug
          Components: Classlib
         Environment: All
            Reporter: Pavel Pervov


The following test succeeds on RI but fails on Harmony.
----------------------------
import java.util.Locale;

class LocaleDisplayLang {
    public static void main(String[] args) {
        Locale p = new Locale("la", "NZ");
        if(p.getDisplayLanguage().equals("Latin")) {
            System.out.println("PASSED");
        } else {
            System.out.println("FAILED: Latin != " + p.getDisplayLanguage());
        }
        Locale.setDefault(p);
        if(p.getDisplayLanguage().equals("Latin")) {
            System.out.println("PASSED");
        } else {
            System.out.println("FAILED: Latin != " + p.getDisplayLanguage());
        }
    }
}
----------------------------
RI prints
PASSED
PASSED
but Harmony prints
PASSED
FAILED

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message