harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Harmony Wiki] Update of "Инструкция по сборке и использованию исходного кода Apache Harmony" by AlexeiFedotov
Date Thu, 31 Jan 2008 14:07:04 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Harmony Wiki" for change notification.

The following page has been changed by AlexeiFedotov:
http://wiki.apache.org/harmony/%d0%98%d0%bd%d1%81%d1%82%d1%80%d1%83%d0%ba%d1%86%d0%b8%d1%8f_%d0%bf%d0%be_%d1%81%d0%b1%d0%be%d1%80%d0%ba%d0%b5_%d0%b8_%d0%b8%d1%81%d0%bf%d0%be%d0%bb%d1%8c%d0%b7%d0%be%d0%b2%d0%b0%d0%bd%d0%b8%d1%8e_%d0%b8%d1%81%d1%85%d0%be%d0%b4%d0%bd%d0%be%d0%b3%d0%be_%d0%ba%d0%be%d0%b4%d0%b0_Apache_Harmony

------------------------------------------------------------------------------
  == Три команды, чтобы собрать свою Java машину ==
  
+ {{{
- === $ svn co https://svn.apache.org/repos/asf/harmony/enhanced/trunk ===
+ $ svn co https://svn.apache.org/repos/asf/harmony/enhanced/trunk ===
- 
- === $ cd trunk ===
+ $ cd trunk ===
- 
- === $ ant -Dauto-fetch=true ===
+ $ ant -Dauto-fetch=true ===
+ }}}
  
  == Введение ==
  
@@ -22, +22 @@

   {i} '''Примечание.''' Данная страница является переводом
[http://harmony.apache.org/quickhelp_contributors.html английской версии]
на сайте. Страница, как и весь проект, находятся в
стадии разработки. Если Вы обнаружили ошибку или
Вам нужна помощь, пишите в список раассылки проекта
по адресу dev@harmony.apache.org.
  
  
- == 1. Требования к системе ==
+ == Требования к системе ==
  [[Anchor(prerequisites)]]
  === Общие требования ===
  Для работы с Harmony необходимо установить следующее
ПО:
+  * Операционная система Linux или Windows
   * Apache Ant версия 1.6.5 или более поздняя 
   * Subversion (svn)
   * Java SE 5 JRE
  
-  (i) '''Примечание.''' Если Вы выходите в Интернет через
прокси-сервер, укажите имя и порт прокси-сервера в
настройках ant и svn. Для этого следуйте указаниям в
документации клиентского приложения. Например, для
использования консольной версии svn внесите соответствующие
изменения в файл {{{~/.subversion/servers}}}. Для работы ant, укажите
следующие значения  для переменной окружения {{{ANT_OPTS}}}:
{{{
+  (i) '''Примечание.''' Если Вы выходите в Интернет через
прокси-сервер, укажите имя и порт прокси-сервера в
настройках ant и svn. Для этого следуйте указаниям документации
клиентского приложения. Например, для использования
консольной версии svn внесите соответствующие изменения
в файл {{{~/.subversion/servers}}}. Для работы ant, установите следующее
значение для переменной окружения {{{ANT_OPTS}}}: {{{-Dhttp.proxyHost=<host>
-Dhttp.proxyPort=<proxy>}}}.
- -Dhttp.proxyHost=<host>
- -Dhttp.proxyPort=<proxy>}}}
  
  === Tребования для отдельных платформ ===
- В зависимости от платформы (см. список поддерживаемых
платформ) вам понадобится ряд других программ, наиболее
общий список которых приводится ниже. 
+ В зависимости от платформы Вам понадобится ряд других
программ, наиболее общий список которых приводится
ниже.
  
  '''Windows'''
   * SDK для платформы Windows
+  * Microsoft Visual Studio .NET 2003 или внешний компилятор:
-  * Microsoft Visual Studio.NET 2003
-  * (по желанию) Внешний компилятор:
-    * Microsoft 32-битный компилятор C/C++, версия 7 или более
поздняя
+    * Компилятор Microsoft C/C++, версия 7 или более поздняя
-    *  Intel C++ Compiler , версия 9.0 
+    * Компилятор Intel C++, версия 9.0
  
  '''Linux'''
   * gcc компилятор, версия 3.3.3 или более поздняя (Версии
до 3.3.3 не тестировались но могут работать.)
@@ -57, +55 @@

   * libxml2-dev
  
  === Дополнительные требования ===
- Отдельные компоненты системы сборки также зависит
от сторонних программных продуктов и библиотек. Поскольку
эти требования постоянно эволюционируют, мы рекомендуем
запустить систему сборки и автоматически загрузить
недостающие компоненты через Интернет. 
+ Отдельные компоненты системы сборки также зависят
от сторонних программных продуктов и библиотек. Поскольку
эти требования постоянно эволюционируют, мы рекомендуем
запустить систему сборки и автоматически загрузить
недостающие компоненты через Интернет. 
  
  Для построения DRLVM отдельным компонентам системы
требуются:
   * Xalan-Java, версия 2.7.0 (копируется из библиотек классов)

   * Cpp Tasks collection, версия 1.0 beta 3 or higher (загружается из
сети) 
   * Ant-Contrib набор задач, версия 0.6 или более поздняя
(загружается из сети) 
   * Zlib библиотека, бинарные файлы, версия 1.2.1 или более
поздняя (загружается из сети) 
-  * Apache Portable Runtime Layer , версия 1.2.6 (загружается из сети)

+  * Apache Portable Runtime Layer, версия 1.2.6 (загружается из сети)

   * APR-util, версия 1.2.6 (загружается из сети) 
   * APR-iconv, версия 1.1.1 (загружается из сети) 
-  * Log4cxx , наиболее поздняя версия, из SVN - 467164 (загружается
из сети) 
+  * Log4cxx, версия 467164 из svn (загружается из сети) 
  
  Данные компоненты необходимы для построения исходного
кода как на Windows, так и на Linux системах.
  
@@ -241, +239 @@

  Для работы с библиотекой классов Harmony, используйте
подробную документацию для этого компонента. 
  Разработчики виртуальной машины DRLVM используют
ВМ, построенную в результате сборки, то есть среду
исполнения, состоящую из DRLVM и библиотеки классов.

  
- = Запуск Java-приложений =
+ == Запуск Java-приложений ==
  Убедитесь, что переменная окружения {{{JAVA_HOME}}} не
имеет значения или указывает на директорию {{{deploy/jre}}}.

  Используйте стандартный синтаксис для запуска Java-приложений
 с помощью программы запуска в директории {{{deploy/jre/bin}}}:

  {{{

Mime
View raw message