harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ilya Berezhniuk (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-5262) [drlvm][gc_cc] GC_CC does not work in debug mode since r583223
Date Sat, 08 Dec 2007 21:57:43 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-5262?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12549756
] 

Ilya Berezhniuk commented on HARMONY-5262:
------------------------------------------

I've tested release build on Windows/x86_64, all tests passed with GC_CC.
I've tried also on another Windows/x86_64 machine (2 cores instead of 4), all tests are passed
for debug build too.

So looks like these assertions on Windows/x86_64 are because of some threading problems in
GC_GEN, which appear on multicore machine.
(It's strange that Linux/x86_64 I used have 16 cores, but all OK...)


> [drlvm][gc_cc] GC_CC does not work in debug mode since r583223
> --------------------------------------------------------------
>
>                 Key: HARMONY-5262
>                 URL: https://issues.apache.org/jira/browse/HARMONY-5262
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: All
>            Reporter: Ilya Berezhniuk
>         Attachments: gc_cc_0003.patch, gc_cc_0005.patch
>
>
> I've tried to pass 'build test' with GC_CC and got a lot of failures, and also several
random hangs.
> When investigating these problems, I've detected that hang occurs in shutdown (HARMONY-5247).
> But tests hanged with GC_CC on M3 snapshot (I've checked this).
> I've found that failures are caused by lots of assertions introduced by threading changes
from HARMONY-4830.
> The attached patch fixes GC_CC to reflect threading changes.
> It also corrects GC_CC according to r599482 which included changes in object layout.
> With this patch the tests still often hang (because of HARMONY-5247).
> But almost all 'build test' tests pass for me on Windows when they do not hang.
> I still have a problem with loading gc_cc library on Linux (tl::MemoryPoolMT can't be
found).
> Also outofemory.Int still fails on x86_64.
> I'll try to fix these remaining problems and update the patch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message