harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Ozhdikhin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-4643) [drlvm][jit][build] DRLVM is not buildable on SLES10 (em64t)
Date Thu, 29 Nov 2007 11:37:43 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-4643?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12546668

Pavel Ozhdikhin commented on HARMONY-4643:

I've built DRLVM with JIT on SLES10 without any problem. Natalya, could you please check if
the issue is still reproducible?

> [drlvm][jit][build] DRLVM is not buildable on SLES10 (em64t)
> ------------------------------------------------------------
>                 Key: HARMONY-4643
>                 URL: https://issues.apache.org/jira/browse/HARMONY-4643
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: x86_64, SLES10, BUILD_CFG=release
>            Reporter: Naumova Natalya 
>            Assignee: Mikhail Fursov
> DRLVM is built by gcc3.3.3, but when we are trying to build DRLVM on SLES10, the compilation
> 1. compilation error in jitrino - 
> In destructor `Jitrino::AbcdSolver::~AbcdSolver()':
>        [cc] .../x86_64-suse-linux/bits/atomicity.h:40: error: inconsistent operand constraints
in an `asm'
> [skip]
> this can be fixed by removing <compilerarg value="-O" /> from build/make/components/vm/jitrino.xml
> the command line for jitrino now contains "-O" and "-O2" options, so it makes sense to
leave the "O2" only.
> 2. then after jitrino successful compilation we have a problems with linking:
> binutils 2.16:
>        [cc] Starting link
>        [cc] `.gnu.linkonce.t._ZN7Jitrino16JavaLabelPrepass11getJavaTypeEPNS_4TypeE' referenced
in section `.rodata' of ../_obj/JavaLabelPrepass.o: defined in discarded section `.gnu.linkonce.t._ZN7Jitrino16JavaLabelPrepass11getJavaTypeEPNS_4TypeE'
of ../_obj/JavaLabelPrepass.o
>        [cc] `.gnu.linkonce.t._ZN7Jitrino3Jet8Compiler5fetchEjRNS0_5JInstE' referenced
in section `.rodata' of ../_obj/trace.o: defined in discarded section `.gnu.linkonce.t._ZN7Jitrino3Jet8Compiler5fetchEjRNS0_5JInstE'
of ../_obj/trace.o
>        [cc] collect2: ld returned 1 exit status
> binutils 2.15:
> build.native.link:
>        [cc] 0 total files to be compiled.
>        [cc] Starting link
>        [cc] /usr/lib64/libc.so: file format not recognized; treating as linker script
>        [cc] /usr/lib64/libc.so:5: parse error
>        [cc] collect2: ld returned 1 exit status
> even in vmcore
> The reason is that there are linker scripts instead of libraries in /usr/lib64/libc.so,
and 2.15 ld doesn't recognize them. 
> It could be solved by adding some linker options to all vm libraries : 
>  <linkerarg value="-nostdlib"/>
> <linkerarg value="-L/lib64"/>
> This all makes DRLVM buildable, but not-working: "./java Hello" doesn't work.
> btw: actually, if we'll have the possibility of compiling with gcc fo higher version
(e.g. 4.1) and ld of 2.16, this problem could be solved by proper way. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message