harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregory Shimansky (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HARMONY-4978) [drlvm][build][EUT] Eclipse3.3 crashes on SLES10 x86
Date Tue, 23 Oct 2007 12:18:50 GMT

     [ https://issues.apache.org/jira/browse/HARMONY-4978?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gregory Shimansky resolved HARMONY-4978.
----------------------------------------

    Resolution: Fixed

I implemented version scripts for linking DRLVM libraries at 587472. Eclipse works for me
now with mozilla-xulrunner package installed.

> [drlvm][build][EUT] Eclipse3.3 crashes on SLES10 x86
> ----------------------------------------------------
>
>                 Key: HARMONY-4978
>                 URL: https://issues.apache.org/jira/browse/HARMONY-4978
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: Linux (SLES10) x86
>            Reporter: Vladimir Beliaev
>            Assignee: Gregory Shimansky
>            Priority: Blocker
>         Attachments: patch.patch
>
>
> Recent CC-based automated testing shows 4.45% pass rate for EUT3.3 on Linux x86:
> http://people.apache.org/~smishura/r585787/Linux_x86/eut33/
> This was caused by moving CC from SLES9 to SLES10 and EUT3.3 start crashing on new OS.
> I've double checked the crash - it turned out that I can't just start Eclipsse3.3 on
SLES10 x86.
> To reproduce:
> 1. download eclipse-SDK-3.3-linux-gtk.tar.gz from http://download.eclipse.org/eclipse/downloads/drops/R-3.3-200706251500
> 2. unpack it, enter resulted 'eclipse' directory
> 3. run the command: 
>     time java -showversion -jar plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar
-data ./workspace
> You'll get the stack dump of about 105-109 frames with the top like:
>         SIGSEGV in VM code.
>         Stack trace:
>           0: little2_nameLength (xmltok.c:-1)
>           1: MOZ_XML_GetBuffer (??:-1)
>           2: MOZ_XML_GetBuffer (??:-1)
> Could someone take a look? Moving to new platform (SLES9->SLES10) causes "regression"
since M3 to be fixed...

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message