harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Varlamov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-4915) [build] Undocumented dependecy from Eclipse.
Date Wed, 10 Oct 2007 04:53:50 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-4915?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12533595
] 

Alexey Varlamov commented on HARMONY-4915:
------------------------------------------

Thanks for pointing this out, doc should be updated.
In fact this is not a strong dependency, supposed you should be able to build with standard
javac as well. 
To do so just supply -Dhy.javac.compiler=modern option when running build, like this:
>ant -Dhy.javac.compiler=modern -Dauto.fetch=true

Well, to be honest I did not test this with federated build, though it works with classlib
and drlvm for sure.

> [build] Undocumented dependecy from Eclipse.
> --------------------------------------------
>
>                 Key: HARMONY-4915
>                 URL: https://issues.apache.org/jira/browse/HARMONY-4915
>             Project: Harmony
>          Issue Type: Bug
>          Components: build - test - ci
>         Environment:      [echo]                    Apache Harmony Federated Build
>      [echo]             ==========================================
>      [echo]             svn rev          :  583048
>      [echo]             operating system :  linux
>      [echo]             architecture     :  x86-32
>      [echo]             ant os name/arch :  Linux/i386
>      [echo]             hosting Java     :  1.6.0_02 (Sun Microsystems Inc.)
>      [echo]             build mode       :  release
>      [echo]             output location  :  target
>      [echo]             DRLVM classlib   :  ../../../working_classlib
>      [echo]             SVN root         :  http://svn.apache.org/repos/asf
>            Reporter: Vasily Chekalkin
>            Priority: Minor
>
> Failed to build Harmony due unresolved dependency on Eclipse. However such dependency
is not described on http://harmony.apache.org/quickhelp_contributors.html.
> BUILD FAILED
> /a/waters/nobackup/src/harmony/enhanced/trunk/build.xml:319: The following error occurred
while executing this line:
> /a/waters/nobackup/src/harmony/enhanced/trunk/working_classlib/build.xml:113: The following
error occurred while executing this line:
> /a/waters/nobackup/src/harmony/enhanced/trunk/working_classlib/make/build-java.xml:116:
The Eclipse compiler class for Ant could not be found. Please place the ECJ JAR in ANT_HOME/lib.
The JAR can be downloaded directly from eclipse.org or copied from COMMON_RESOURCES/depends/jars/ecj_3.x
folder after the fetch-depends target for JDKTOOLS has been run.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message