harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From var...@apache.org
Subject svn commit: r584063 - in /harmony/standard/site: docs/quickhelp_contributors.html xdocs/quickhelp_contributors.xml
Date Fri, 12 Oct 2007 06:20:41 GMT
Author: varlax
Date: Thu Oct 11 23:20:40 2007
New Revision: 584063

URL: http://svn.apache.org/viewvc?rev=584063&view=rev
Log:
Fixed HARMONY-4915 Undocumented dependecy on ECJ.

Modified:
    harmony/standard/site/docs/quickhelp_contributors.html
    harmony/standard/site/xdocs/quickhelp_contributors.xml

Modified: harmony/standard/site/docs/quickhelp_contributors.html
URL: http://svn.apache.org/viewvc/harmony/standard/site/docs/quickhelp_contributors.html?rev=584063&r1=584062&r2=584063&view=diff
==============================================================================
--- harmony/standard/site/docs/quickhelp_contributors.html (original)
+++ harmony/standard/site/docs/quickhelp_contributors.html Thu Oct 11 23:20:40 2007
@@ -247,6 +247,12 @@
         the version of the tool you use. For example, edit <code>~/.subversion/servers</code>
         file for console version of <code>svn</code>.
       </p>
+                                <p>Optional (but recommended) prerequisite is an Eclipse
Java Compiler (ECJ), version 3.2 or higher. 
+      You need to <a href="http://download.eclipse.org/eclipse/downloads/">download</a>

+      standalone ecj.jar and put it to <code>ANT_HOME/lib</code> directory.
+      Alternatively, you can switch to any other Java 1.5 compiler supported by Ant
+      via overriding <code>hy.javac.compiler</code> property.
+      </p>
                                 <p>
         The other prerequisites for building Harmony differ by platform. For
         examples of platform-specific setup instructions, please see these
@@ -699,12 +705,6 @@
 On Linux:
 $ sh build.sh test</pre>
 
-            <p class="note">Note</p>
-            <p class="notetext">
-              The <code>kernel</code> tests do not currently pass.
-              To succeed, use <code>C Unit</code> and
-              <code>Smoke</code> tests.
-            </p>
           </li>
         </ol>
                                 <p>

Modified: harmony/standard/site/xdocs/quickhelp_contributors.xml
URL: http://svn.apache.org/viewvc/harmony/standard/site/xdocs/quickhelp_contributors.xml?rev=584063&r1=584062&r2=584063&view=diff
==============================================================================
--- harmony/standard/site/xdocs/quickhelp_contributors.xml (original)
+++ harmony/standard/site/xdocs/quickhelp_contributors.xml Thu Oct 11 23:20:40 2007
@@ -91,6 +91,13 @@
         the version of the tool you use. For example, edit <code>~/.subversion/servers</code>
         file for console version of <code>svn</code>.
       </p>
+      <p>Optional (but recommended) prerequisite is an Eclipse Java Compiler (ECJ),
version 3.2 or higher. 
+      You need to <a href="http://download.eclipse.org/eclipse/downloads/">download</a>

+      standalone ecj.jar and put it to <code>ANT_HOME/lib</code> directory.
+      Alternatively, you can switch to any other Java 1.5 compiler supported by Ant
+      via overriding <code>hy.javac.compiler</code> property.
+      </p>
+
       <p>
         The other prerequisites for building Harmony differ by platform. For
         examples of platform-specific setup instructions, please see these
@@ -514,12 +521,6 @@
 On Linux:
 $ sh build.sh test</pre>
 
-            <p class="note">Note</p>
-            <p class="notetext">
-              The <code>kernel</code> tests do not currently pass.
-              To succeed, use <code>C Unit</code> and
-              <code>Smoke</code> tests.
-            </p>
           </li>
         </ol>
         <p>



Mime
View raw message