harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Pervov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-3553) [drlvm][jit] get rid of jit helpers IDs re-mapping
Date Thu, 11 Oct 2007 11:34:52 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-3553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12534013

Pavel Pervov commented on HARMONY-3553:

I'd suggest making vm_helper_get_interruptibility_kind and vm_helper_get_calling_convention
a "check-bounds-and-index-in-the-array" kind of functions, integrating this information into
helpers list. This will reduce readability of the code a lot. (I see, there is TODO in the
patch, why not doing it right now?) 

Also, comments from vm_helper_get_interruptibility_kind switch be better moved to the array,
describing the helpers.

P.S. I wonder, why remapping existed in Jitrino first of all...

> [drlvm][jit] get rid of jit helpers IDs re-mapping
> --------------------------------------------------
>                 Key: HARMONY-3553
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3553
>             Project: Harmony
>          Issue Type: Sub-task
>          Components: DRLVM
>            Reporter: Alexey Varlamov
>            Assignee: Alexey Varlamov
>            Priority: Minor
>         Attachments: H3553.jit.diff, H3553.vm.diff
> Currently Jitrino does 1:1 remapping of VM_RT_SUPPORT enum to RuntimeHelperId enum. This
is excessive and should be dropped.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message