harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Qi Ji (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-4890) [drlvm][gc][EUT] 37% tests crashed in gc_gen_adapt
Date Fri, 12 Oct 2007 12:40:50 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-4890?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12534280 ] 

Qi Ji commented on HARMONY-4890:
--------------------------------

Hi, Vladimir,
    I do all these steps all over again, but still can't reproduce your stack trace. Here is the output:

[lwang40@ssgngmm eclipse-testing]$ /home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/bin/java -showversion -jar eclipse/plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar -application org.eclipse.test.uitestapplication -dev bin -data workspace formatter=org.apache.tools.ant.taskdefs.optional.junit.XMLJUnitResultFormatter,log.xml -testpluginname org.eclipse.jdt.core.tests.builder -classname org.eclipse.jdt.core.tests.builder.BuilderTests
Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
java version "1.5.0" 
pre-alpha : not complete or compatible
svn = r, (Oct 12 2007), Linux/em64t/gcc 4.0.2, debug build
http://harmony.apache.org
Failure while running test org.eclipse.jdt.core.tests.builder.BuildpathTests#testIncompatibleJdkLEvelOnProject()!!!
Actual output is:
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/accessibility.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/annotation.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/applet.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/archive.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/auth.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/awt.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/beans.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/concurrent.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/crypto.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/imageio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/instrument.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/jndi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/lang-management.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/logging.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/math.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/misc.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio_char.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/pack200.jar\' which requires a 1.4 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/prefs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/print.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/regex.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/rmi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sound.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sql.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/suncompat.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/swing.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/text.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/vmmagic-20070207.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/x-net.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]"
 
Failure while running test org.eclipse.jdt.core.tests.builder.BuildpathTests#testIncompatibleJdkLEvelOnProject()!!!
Actual output is:
                "Problem : The project cannot be built until build path errors are resolved [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/accessibility.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/annotation.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/applet.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/archive.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/auth.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/awt.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/beans.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/concurrent.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/crypto.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/imageio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/instrument.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/jndi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/lang-management.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/logging.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/math.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/misc.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio_char.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/pack200.jar\' which requires a 1.4 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/prefs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/print.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/regex.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/rmi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sound.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sql.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/suncompat.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/swing.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/text.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/vmmagic-20070207.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/x-net.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]"
 
Failure while running test org.eclipse.jdt.core.tests.builder.BuildpathTests#testIncompatibleJdkLEvelOnWksp()!!!
Actual output is:
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/accessibility.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/annotation.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/applet.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/archive.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/auth.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/awt.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/beans.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/concurrent.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/crypto.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/imageio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/instrument.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/jndi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/lang-management.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/logging.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/math.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/misc.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio_char.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/pack200.jar\' which requires a 1.4 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/prefs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/print.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/regex.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/rmi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sound.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sql.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/suncompat.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/swing.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/text.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/vmmagic-20070207.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/x-net.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <1>]"
 
Failure while running test org.eclipse.jdt.core.tests.builder.BuildpathTests#testIncompatibleJdkLEvelOnWksp()!!!
Actual output is:
                "Problem : The project cannot be built until build path errors are resolved [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/accessibility.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/annotation.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/applet.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/archive.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/auth.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/awt.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/beans.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/concurrent.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/crypto.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/imageio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/instrument.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/jndi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/lang-management.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/logging.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/luni.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/math.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/misc.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/nio_char.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/pack200.jar\' which requires a 1.4 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/prefs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/print.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/regex.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/rmi.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security-kernel-stubs.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/security.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sound.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/sql.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/suncompat.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/swing.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/text.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/vmmagic-20070207.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]\n" + 
                "Problem : Incompatible .class files version in required binaries. Project \'Project\' is targeting a 1.2 runtime, but is compiled against \'home/lwang40/jqi2_harmony_2007.07.18/working_vm_1008/build/lnx_em64t_gcc_debug/deploy/jdk/jre/lib/boot/x-net.jar\' which requires a 1.5 runtime [ resource : </Project> range : <-1,-1> category : <10> severity : <2>]"
 
Failure while running test org.eclipse.jdt.core.tests.builder.IncrementalTests#testRenameMainType()!!!
Actual output is:
                "Problem : The hierarchy of the type C is inconsistent [ resource : </Project/src/p/C.java> range : <25,26> category : <40> severity : <2>]\n" + 
                "Problem : A cannot be resolved to a type [ resource : </Project/src/p/B.java> range : <35,36> category : <40> severity : <2>]\n" + 
                "Problem : The public type _A must be defined in its own file [ resource : </Project/src/p/A.java> range : <25,27> category : <40> severity : <2>]"

> [drlvm][gc][EUT] 37% tests crashed in gc_gen_adapt
> --------------------------------------------------
>
>                 Key: HARMONY-4890
>                 URL: https://issues.apache.org/jira/browse/HARMONY-4890
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: Linux / x86_64
>            Reporter: Vladimir Beliaev
>            Assignee: Xiao-Feng Li
>            Priority: Blocker
>
> I'm enabling EUT3.3 on Linux x86_64 (SLES10).
> A bit set of suites crashed with the following dump:
>      [java] SIGSEGV in VM code.
>      [java] Stack trace:
>      [java]   0: gc_gen_adapt(GC_Gen*, long long) (??:-1)
>      [java]   1: ?? (??:-1)
>      [java]   2: ?? (??:-1)
>      [java]   3: apr_atomic_casptr (atomic/unix/apr_atomic.c:376)
>      <skipped...>
> which allows to guess it is GC GEN issue to be fixed.
> Could someone take a look, please?
> Thanks
> Vladimir Beliaev

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message