harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Popov (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HARMONY-4340) [jdktools][tools] update javac wrapper with ECJ 3.3
Date Wed, 04 Jul 2007 13:12:04 GMT

     [ https://issues.apache.org/jira/browse/HARMONY-4340?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ivan Popov updated HARMONY-4340:
--------------------------------

    Patch Info: [Patch Available]

> [jdktools][tools] update javac wrapper with ECJ 3.3
> ---------------------------------------------------
>
>                 Key: HARMONY-4340
>                 URL: https://issues.apache.org/jira/browse/HARMONY-4340
>             Project: Harmony
>          Issue Type: Bug
>          Components: JDK
>         Environment: all platforms
>            Reporter: Ivan Popov
>         Attachments: jdktools_ecj.patch
>
>
> After adjusting Harmony dependencies to Eclipse 3.3 (r552639), javac wrapper fork jdktools
component starts to fail:
> $HY_JDK/bin/javac -version
> java.lang.ClassNotFoundException: org.eclipse.jdt.internal.compiler.batch.Main
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:894)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:575)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
>         at org.apache.harmony.tools.javac.Compiler.initializeMainClass(Compiler.java:143)
>         at org.apache.harmony.tools.javac.Compiler.initialize(Compiler.java:99)
>         at org.apache.harmony.tools.javac.Compiler.<init>(Compiler.java:91)
>         at org.apache.harmony.tools.javac.Compiler.main(Compiler.java:55)
>         at org.apache.harmony.tools.javac.Main.compile(Main.java:78)
>         at org.apache.harmony.tools.javac.Main.compile(Main.java:52)
>         at org.apache.harmony.tools.javac.Main.main(Main.java:33)
> Uncaught exception in main:
> java.lang.NullPointerException
>         at org.apache.harmony.tools.javac.Compiler.main(Compiler.java:60)
>         at org.apache.harmony.tools.javac.Main.compile(Main.java:78)
>         at org.apache.harmony.tools.javac.Main.compile(Main.java:52)
>         at org.apache.harmony.tools.javac.Main.main(Main.java:33)
> The problem is that javac wrapper looks for "ecj_3.3M7.jar" which was switched to "ecj_3.3.jar".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message