harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Zakharov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-1728) [classlib][awt] Let's replace static lcms library to dynamic
Date Mon, 23 Apr 2007 09:34:15 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-1728?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12490872
] 

Alexei Zakharov commented on HARMONY-1728:
------------------------------------------

Sure, because liblcms.a comes with liblcms1-dev package, see [1]. And this package is already
in the list of Linux prerequisites - see [2]. 

[1] http://packages.debian.org/stable/libdevel/liblcms1-dev
[2] http://harmony.apache.org/quickhelp_contributors.html


> [classlib][awt] Let's replace static lcms library to dynamic
> ------------------------------------------------------------
>
>                 Key: HARMONY-1728
>                 URL: https://issues.apache.org/jira/browse/HARMONY-1728
>             Project: Harmony
>          Issue Type: Bug
>          Components: Classlib
>         Environment: IA64
>            Reporter: Nikolay Chugunov
>
> Now DRL classlib use static library of lcms and failed to build on IA64 with error:
> Missing dependency.  The file from:
>   /usr/lib/liblcms.a should be linked to:
>   depends/libs/build/lcms/liblcms.ipf
> But /usr/lib/liblcms.a doesn't exist.
> Static library is not exists in all OS, for example Debian package for ia64 and i386(http://packages.debian.org/stable/libs/liblcms1)
contains only dynamic library.
> For compatibility purpose it is better to use dynamic library.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message