harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-3765) [drlvm][general] markup macros for thread unsafe regions
Date Fri, 27 Apr 2007 04:04:15 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-3765?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12492177
] 

Nathan Beyer commented on HARMONY-3765:
---------------------------------------

Can we change the name of this file? Perhaps to something like 'nonconcurrent', 'threadsafety'
or 'threadunsafe'? The content isn't about marking non-atomic state changes, just indicating
that a region isn't safe for concurrent access, correct? A region that's safe for concurrent
access doesn't have to be atomic.

> [drlvm][general] markup macros for thread unsafe regions
> --------------------------------------------------------
>
>                 Key: HARMONY-3765
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3765
>             Project: Harmony
>          Issue Type: Improvement
>          Components: DRLVM
>            Reporter: Ilya Leviev
>         Assigned To: Nathan Beyer
>         Attachments: HARMONY-3765-marking_macros.patch
>
>
> Sometimes TC report about race conditions that not affect correctness of execution. So
I have prepared special functionality for prevention of further alarms on this race conditions.
> Notes: 
> The patch add new header file (port/include/port_nonatomic.h) which define macros that
mark start and end points of code area where thread unsafe operations are performed. 
> Thanks to Alexey Varlamov for reviewing the patch (see HARMONY-3537)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message