harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Zakharov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-2869) [drlvm] [build] build fails on ant 1.7
Date Mon, 05 Feb 2007 17:26:05 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-2869?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470286
] 

Alexei Zakharov commented on HARMONY-2869:
------------------------------------------

Anton, thanks. I've changed your patch a little bit - now the build accepts any ant version
that is above 1.6.5. The fix was committed at the revision 503775. Please verify that it solves
the original problem. BTW, I don't see much sense in "check.ant.version" target at all since
DRLVM build breaks on pre-1.6.5 ant before executing this target. For example it breaks on
ant 1.6.2  while trying to parse classlib/trunk/make/properties.xml that is not 1.6.2 compliant
with the following message:

BUILD FAILED
C:\Java\harmony\enhanced\drlvm\trunk\build\make\build.xml:65: The following erro
r occurred while executing this line:
C:\Java\harmony\enhanced\classlib\trunk\make\properties.xml:37: Class org.apache
.tools.ant.taskdefs.ConditionTask doesn't support the "else" attribute.


So there is no user-friendly message anyway. So we probably need to refator current build.xml
& setup.xml.

> [drlvm] [build]  build fails on ant 1.7
> ---------------------------------------
>
>                 Key: HARMONY-2869
>                 URL: https://issues.apache.org/jira/browse/HARMONY-2869
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: Linux
>            Reporter: Anton Luht
>         Assigned To: Alexei Zakharov
>            Priority: Minor
>         Attachments: H2869.patch
>
>
> Rule for checking Ant versions fails on Ant 1.7:
> You have wrong version of ANT :Apache Ant version 1.7.0 compiled on December 13 2006
> * Make sure you have Ant 1.6.5 or above installed from
> * http://ant.apache.org/bindownload.cgi and that ANT_HOME environment
> * variable points out to the Ant installation dir, e.g.
> * export ANT_HOME=/usr/local/ant_1.6.5
> The following quick patch solves the problem:
> Index: enhanced/drlvm/trunk/build/make/setup.xml
> ===================================================================
> --- enhanced/drlvm/trunk/build/make/setup.xml       (revision 490124)
> +++ enhanced/drlvm/trunk/build/make/setup.xml       (working copy)
> @@ -33,11 +33,18 @@
>          <fail>
>              <condition>
>                  <not>
> -                    <and>
> -                        <equals arg1="${ch1}" arg2="1" />
> -                        <equals arg1="${ch2}" arg2="6" />
> -                        <equals arg1="${ch3}" arg2="5" />
> -                    </and>
> +                    <or>
> +                        <and>
> +                            <equals arg1="${ch1}" arg2="1" />
> +                            <equals arg1="${ch2}" arg2="6" />
> +                            <equals arg1="${ch3}" arg2="5" />
> +                        </and>
> +                        <and>
> +                            <equals arg1="${ant.version1}" arg2="1" />
> +                            <equals arg1="${ant.sub.version}" arg2="7" />
> +                            <equals arg1="${ant.sub.sub.version}" arg2="0" />
> +                        </and>
> +                    </or>
>                  </not>
>              </condition>
>  * You have wrong version of ANT :${ant.version}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message