harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vasily Zakharov (JIRA)" <j...@apache.org>
Subject [jira] Created: (HARMONY-3211) [ibm vme][netbeans] IBM VM reports supported version 1.4
Date Tue, 20 Feb 2007 17:52:05 GMT
[ibm vme][netbeans] IBM VM reports supported version 1.4
--------------------------------------------------------

                 Key: HARMONY-3211
                 URL: https://issues.apache.org/jira/browse/HARMONY-3211
             Project: Harmony
          Issue Type: Bug
          Components: App-Oriented Bug Reports, VM
            Reporter: Vasily Zakharov


For now, IBM VM reports in system properties

java.specification.version=1.4
java.version=1.4.2 subset

while it supports 1.5 pretty well.

As a result, for example, Netbeans fails to start many of its components with the following
diagnostic:
"The Java platform version 1.5 or higher was requested but only 1.4 is running."

As a workaround, setting the properties manually can be helpful:

-Djava.specification.version=1.5 -Djava.version=1.5

or for Netbeans:

nb.exe --jdkhome Harmony\working_classlib\deploy\jdk -J-Djava.specification.version=1.5 -J-Djava.version=1.5

Here's the discussion of this issue on the mailing list:
http://article.gmane.org/gmane.comp.java.harmony.devel/24234


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message