harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregory Shimansky (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-2798) [drlvm] VM cunit test test_native_basic sometimes crashes on win32 SMP
Date Fri, 12 Jan 2007 11:41:27 GMT

    [ https://issues.apache.org/jira/browse/HARMONY-2798?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12464183
] 

Gregory Shimansky commented on HARMONY-2798:
--------------------------------------------

The test fails quite often for me on windows 2003 server on P4 with HT.

> [drlvm] VM cunit test test_native_basic sometimes crashes on win32 SMP
> ----------------------------------------------------------------------
>
>                 Key: HARMONY-2798
>                 URL: https://issues.apache.org/jira/browse/HARMONY-2798
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>         Environment: Windows 2003 server on P4 with HT enabled
>            Reporter: Gregory Shimansky
>
> The test test_native_basic fails on windows from time to time in 3 different ways. The
most common way is to exit silently on shutdown while function main has returned 0, and all
tests passed. Two other ways are access to non-writable memory and MS debug CRT heap validation
on shutdown.
> In all 3 cases I cannot debug the program because it fails after function main has finished.
Looks like some race condition causes memory corruption. Probably running the program from
under VS.NET could help to debug it.
> To run the test many times I've written the following script in cygwin bash:
> i=0; while true; do ./test_native_basic.exe -Dorg.apache.harmony.vm.vmdir=d:/work/harmony/enhanced/trunk/working_vm/build/win_ia32_msvc_debug/deploy/jdk/jre/bin/default
-Djava.home=d:/work/harmony/enhanced/trunk/working_vm/build/win_ia32_msvc_debug/deploy/jdk/jre;
ec=$?; echo $i $ec; test $ec != 0 && break; i=$[i+1]; done
> Note, to run test_native_basic in console you need to set PATH to DRLVM bin and bin/default
directories.
> Note2, it looks like this bug requires SMP or at least HT enabled system, and is not
reproducible on single processor computers like laptops.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message