harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Varlamov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-813) [drlvm] j.l.Package fails to find version info for bootstrap packages
Date Tue, 08 Aug 2006 03:29:15 GMT
    [ http://issues.apache.org/jira/browse/HARMONY-813?page=comments#action_12426407 ] 
            
Alexey Varlamov commented on HARMONY-813:
-----------------------------------------

It worked - the only difference that I tried it with kernel.jar. This issue relates to bootstrap
loader/packages only, URLClassLoader worked fine.
The point is that "java.lang" package is spread over several jars so we could read this info
from any of them (or even refuse to accept classes if manifest info for the package do not
match).
The DRLVM only takes the first related jar, and I guess J9 does the same.

OK, I will look if I can add independent test for this issue.

> [drlvm] j.l.Package fails to find version info for bootstrap packages
> ---------------------------------------------------------------------
>
>                 Key: HARMONY-813
>                 URL: http://issues.apache.org/jira/browse/HARMONY-813
>             Project: Harmony
>          Issue Type: Bug
>          Components: DRLVM
>            Reporter: Alexey Varlamov
>         Assigned To: Geir Magnusson Jr
>            Priority: Trivial
>         Attachments: pkg-info.patch
>
>
> j.l.Package never provides version info about the implementation and specification of
bootstrap packages, even if requested info is presented in manifest.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message