harmony-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "George Harley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HARMONY-1084) Patches to move up to 5.0, and use new IBM VME
Date Tue, 08 Aug 2006 16:58:15 GMT
    [ http://issues.apache.org/jira/browse/HARMONY-1084?page=comments#action_12426638 ] 
            
George Harley commented on HARMONY-1084:
----------------------------------------

Oliver, 

Updates for Eclipse committed in revision 429730 along with a couple of other minor tweaks
required for building the new version 1.0.2 of the plug-in. Eclipse users can upgrade from
the following update site ...

http://svn.apache.org/viewcvs.cgi/*checkout*/incubator/harmony/enhanced/tools/trunk/eclipse/org.apache.harmony.eclipse.site


Would be grateful if you could confirm that the update site works. 

Best regards, 
George

> Patches to move up to 5.0, and use new IBM VME
> ----------------------------------------------
>
>                 Key: HARMONY-1084
>                 URL: http://issues.apache.org/jira/browse/HARMONY-1084
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Oliver Deakin
>         Assigned To: George Harley
>         Attachments: VME4.classlib.update.diff, VME4.eclipse.plugin.update.diff
>
>
> This JIRA will contain the patches required to use the new IBM VME, as announced on the
dev list.
> VME4.classlib.update.diff will contain all the classlib updates required, which consist
of:
>  - Change Java build target from jsr14 to 1.5
>  - Change the bootclasspath system property name from com.ibm.oti.system.class.path to
org.apache.harmony.boot.class.path
>  - Create a new org.apache.harmony.luni.platform.Environment class that contains two
(currently stubbed) getenv() methods. Once these methods are implemented, VM writers will
be able to redirect System.getenv() calls to this class.
>  - Rename clearvm.dll/libclearvm.so to harmonyvm.dll/libharmonyvm.so, and update the
launchers reference to this library.
>  - Update tests.api.java.lang.reflect.ArrayTest and tests.api.java.lang.ThreadGroupTest
to reflect changes between 1.4 and 5.0 behaviour.
> VME4.eclipse.plugin.update.diff will contain all the Eclipse plugin updates required,
which consist of:
>  - Rename clearvm.properties to harmonyvm.properties, and update the Eclipse plugin to
find this file.
> Please do not apply these patches until the new VME is available for download. I will
announce this to the list at the appropriate time.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message