hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From andronat_asf <andronat_...@hotmail.com>
Subject Re: Aggregators problem
Date Tue, 20 Aug 2013 08:00:23 GMT
Hey, sorry for the late response,

you need to implement at least two methods:

1) aggregate(VERTEX vertex, M value) (!!! NOT aggregate(VERTEX vertex, M oldValue, M newValue)
!!!)
2) getValue()

The first method is called in every superstep and gets the value of the vertex. Then the same
method is used on the master aggregator to get and summarize the values of the slave aggregators.
The second method is called from the AggregatorRunner to read the end value of master aggregator.
Then (the AggregatorRunner) published the value to all vertexes.

The finalizeAggregate() is a function that is called in the end of the master aggregation,
just before the results are published to slaves.

If you show us some code, we might help you more on what's going on.

Cheers,
Anastasis

On 17 Αυγ 2013, at 12:38 π.μ., ikapoura@csd.auth.gr wrote:

> Hey again it's me with the aggregators again ^^
> 
>  The problem now is that the aggregators are working but when I want to get the value
it returns the value I use at the constructor of the aggregator. I have implemented getValue()
and aggregate(). I tried implementing finalizeAggregate() but it didn't help.
>  So is this an implementation problem or there is some sort of problem with the master
aggregator?
> 
> Ilias
> 
> 


Mime
View raw message