hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zhaoguo wang <tigerwang1...@gmail.com>
Subject ask for help
Date Tue, 13 Sep 2011 06:45:06 GMT
Hello everyone:

 I'm new to both HAMA and Hadoop. When I try to set up hama with hdfs
on the same single node. I have the following problems: First I tried
with hama-0.3.0-incubating, when hama's bsp was setting up and tried
to communicate
with the namenode of HDFS.  The connection is refused on the side of hama.
Then I check the log of the HDFS, it has the following infomation:
Incorrect header or version mismatch from got version
3 expected version 4.

To avoid the mismatch problem, I also tried hadoop-0.20.2 and hadoop-0.21.0.
The same problem happened again when I used hama with  hadoop-0.20.2.

When I use  hadoop-0.21.0, the problem changed.
The following exception is thrown in the log of hdfs instead of
mismatch problem:

2011-09-13 14:37:24,264 INFO org.apache.hadoop.ipc.Server: IPC Server
listener on 9000: readAndProcess threw exception java.io.IOException:
Unable to read authentication method. Count of bytes read: 0
java.io.IOException: Unable to read authentication method
       at org.apache.hadoop.ipc.Server$Connection.readAndProcess(Server.java:1079)
       at org.apache.hadoop.ipc.Server$Listener.doRead(Server.java:525)
       at org.apache.hadoop.ipc.Server$Listener$Reader.run(Server.java:332)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
       at java.lang.Thread.run(Thread.java:636)

I have no idea, what happened. Anyone can give me some suggestions?
Zhaoguo Wang, Parallel Processing Institute, Fudan University

Address: Room 320, Software Building, 825 Zhangheng Road, Shanghai, China


View raw message