hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Himanshu Gahlot <himanshu.gahlo...@gmail.com>
Subject Hama not using existing Zookeeper quorom
Date Tue, 12 Jul 2011 00:00:54 GMT

I am trying to run hama in distributed mode using an already running
zookeeper quorum. Whenever I try to run start-bspd.sh it is unable to
use the existing zookeeper and tries to start a new instance of
zookeeper which fails by throwing "Address already in use error".

Here is the stdout:

-bash-3.2$ bin/start-bspd.sh
Enter passphrase for key '/home/hgahlot/.ssh/id_dsa': Enter passphrase
for key '/home/hgahlot/.ssh/id_dsa': Enter passphrase for key
<worker1>.cnet.com: starting zookeeper, logging to

Nothing happens after this. The hama-zookeeper log is as follows:

-bash-3.2$ cat logs/hama-hgahlot-<worker1>.cnet.com.log
2011-07-11 16:47:27,935 INFO
org.apache.zookeeper.server.quorum.QuorumPeerConfig: Defaulting to
majority quorums
2011-07-11 16:47:28,198 INFO
org.apache.zookeeper.server.quorum.QuorumPeerMain: Starting quorum
2011-07-11 16:47:28,468 INFO
org.apache.zookeeper.server.NIOServerCnxn: binding to port
2011-07-11 16:47:28,469 ERROR org.apache.hama.zookeeper.QuorumPeer:
Exception during ZooKeeper startup - exiting...
java.net.BindException: Address already in use
        at sun.nio.ch.Net.bind(Native Method)
        at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119)
        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52)
        at org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:144)
        at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:121)
        at org.apache.hama.zookeeper.QuorumPeer.runZKServer(QuorumPeer.java:80)
        at org.apache.hama.zookeeper.QuorumPeer.run(QuorumPeer.java:70)
        at org.apache.hama.ZooKeeperRunner.run(ZooKeeperRunner.java:36)
        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:79)
        at org.apache.hama.ZooKeeperRunner.main(ZooKeeperRunner.java:41)

The hama-site.xml config is as follows:

    <description>The address of the bsp master server. Either the
    literal string "local" or a host:port for distributed mode

      The name of the default file system. Either the literal string
      "local" or a host:port for HDFS.

    <description>Comma separated list of servers in the ZooKeeper Quorum.
    For example, "host1.mydomain.com,host2.mydomain.com,host3.mydomain.com".
    By default this is set to localhost for local and pseudo-distributed modes
    of operation. For a fully-distributed setup, this should be set to a full
    list of ZooKeeper quorum servers. If HAMA_MANAGES_ZK is set in hama-env.sh
    this is the list of servers which we will start/stop zookeeper on.

Why is hama trying to invoke an instance of zookeeper instead of using
the already running zookeeper ?


View raw message