hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Minho Kim (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HAMA-924) Zookeeper error on hama cluster that already run zookeeper
Date Mon, 05 Jan 2015 09:48:34 GMT
Minho Kim created HAMA-924:
------------------------------

             Summary: Zookeeper error on hama cluster that already run zookeeper
                 Key: HAMA-924
                 URL: https://issues.apache.org/jira/browse/HAMA-924
             Project: Hama
          Issue Type: Bug
    Affects Versions: 0.6.4
         Environment: HDP cluster(2.1)
Hadoop version(2.4.0)
Zookeeper version(3.4.5)
            Reporter: Minho Kim
            Priority: Minor


I tried to install hama on hdp cluster(ver. 2.1).
In my cluster, zookeeper was already installed. 

So I set hama-site.xml as below:
<configuration>
    <property>
        <name>bsp.master.address</name>
        <value>master.hama.com:40000</value>
    </property>
    <property>
        <name>fs.defaultFS</name>
        <value>hdfs://master.hama.com:8020</value>
    </property>
    <property>
        <name>hama.zookeeper.quorum</name>
      <value>slave1.hama.com,slave2.hama.com,master.hama.com</value>
    </property>
    <property>
        <name>hama.zookeeper.property.clientPort</name>
        <value>2181</value>
    </property>
</configuration>

As I run 'start-bspd.sh'for doing hama cluster , the below message was shown. 
master.hama.com: starting zookeeper, logging to /root/hama-0.6.4/bin/../logs/hama-root-zookeeper-master.hama.com.out
slave2.hama.com: starting zookeeper, logging to /root/hama-0.6.4/bin/../logs/hama-root-zookeeper-slave2.hama.com.out
slave1.hama.com: starting zookeeper, logging to /root/hama-0.6.4/bin/../logs/hama-root-zookeeper-slave1.hama.com.out
starting bspmaster, logging to /root/hama-0.6.4/bin/../logs/hama-root-bspmaster-master.hama.com.out
localhost: starting groom, logging to /root/hama-0.6.4/bin/../logs/hama-root-groom-master.hama.com.out

Then, when I run jps command, I could figure out that process has been working properly as
below.
22003 RunJar
11510 Jps
20754 storm-rest-0.9.1.2.1.7.0-784.jar
2744 GroomServer$BSPPeerChild
24452 NameNode
11446 GroomServerRunner
2768 GroomServer$BSPPeerChild
21003 AmbariServer
17176 HMaster
20424 core
14850 QuorumPeerMain
20272 Bootstrap
18626 RunJar
11360 BSPMasterRunner
15668 RunJar

However, I can find the messase which is 'java.net.BindException: Address already in use'
in hama-root-zookeeper-master-hama.com.log.
- Full logs:
2015-01-05 11:03:26,186 ERROR org.apache.hama.zookeeper.QuorumPeer: Exception during ZooKeeper
startup - exiting...
java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:444)
    at sun.nio.ch.Net.bind(Net.java:436)
    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:67)
    at org.apache.zookeeper.server.NIOServerCnxnFactory.configure(NIOServerCnxnFactory.java:95)
    at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:130)
    at org.apache.hama.zookeeper.QuorumPeer.runZKServer(QuorumPeer.java:119)
    at org.apache.hama.zookeeper.QuorumPeer.runZooKeeper(QuorumPeer.java:92)
    at org.apache.hama.zookeeper.QuorumPeer.run(QuorumPeer.java:75)
    at org.apache.hama.ZooKeeperRunner.run(ZooKeeperRunner.java:36)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
    at org.apache.hama.ZooKeeperRunner.main(ZooKeeperRunner.java:41)

I think that Hama examples are working normally in hama cluster.
Then, what is this log? Does it mean that exception in zookeeper cluster already installed
has not been yet handled?




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message