hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HAMA-921) Polish doSuperstep() function and VertexMessageIterable class
Date Mon, 06 Oct 2014 23:49:34 GMT

    [ https://issues.apache.org/jira/browse/HAMA-921?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14161224#comment-14161224
] 

Edward J. Yoon commented on HAMA-921:
-------------------------------------

+1

> Polish doSuperstep() function and VertexMessageIterable class
> -------------------------------------------------------------
>
>                 Key: HAMA-921
>                 URL: https://issues.apache.org/jira/browse/HAMA-921
>             Project: Hama
>          Issue Type: Improvement
>          Components: graph
>    Affects Versions: 0.6.4
>            Reporter: Anastasis Andronidis
>            Priority: Minor
>              Labels: refactoring
>             Fix For: 0.7.0
>
>         Attachments: HAMA-921.patch
>
>
> I tried to polish the code around the doSuperstep() function and VertexMessageIterable
class. I got rid off things that are a little bit tricky to understand and I think that this
patch is more readable. Please comment, if something is not understandable or fluent, must
be changed. The point is to have nice and readable code.
> The functionality is exactly the same as the old code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message